summaryrefslogtreecommitdiff
path: root/dev-python/click/click-8.0.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/click/click-8.0.1-r1.ebuild')
-rw-r--r--dev-python/click/click-8.0.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/click/click-8.0.1-r1.ebuild b/dev-python/click/click-8.0.1-r1.ebuild
new file mode 100644
index 000000000000..35ac6e554d5a
--- /dev/null
+++ b/dev-python/click/click-8.0.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="https://github.com/pallets/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://palletsprojects.com/p/click/ https://pypi.org/project/click/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+IUSE="examples"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/docutils-0.14' \
+ dev-python/pallets-sphinx-themes \
+ dev-python/sphinxcontrib-log_cabinet \
+ dev-python/sphinx-issues
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}