summaryrefslogtreecommitdiff
path: root/dev-python/cli-helpers/cli-helpers-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cli-helpers/cli-helpers-9999.ebuild')
-rw-r--r--dev-python/cli-helpers/cli-helpers-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/cli-helpers/cli-helpers-9999.ebuild b/dev-python/cli-helpers/cli-helpers-9999.ebuild
new file mode 100644
index 000000000000..fa2b087f7224
--- /dev/null
+++ b/dev-python/cli-helpers/cli-helpers-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Python helpers for common CLI tasks"
+HOMEPAGE="
+ https://cli-helpers.rtfd.io/
+ https://github.com/dbcli/cli_helpers/
+ https://pypi.org/project/cli-helpers/
+"
+EGIT_REPO_URI="https://github.com/dbcli/cli_helpers.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest