summaryrefslogtreecommitdiff
path: root/dev-python/clang-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/clang-python')
-rw-r--r--dev-python/clang-python/Manifest1
-rw-r--r--dev-python/clang-python/clang-python-14.0.0.9999.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/clang-python/Manifest b/dev-python/clang-python/Manifest
index e29c7feea184..451d41e69c3a 100644
--- a/dev-python/clang-python/Manifest
+++ b/dev-python/clang-python/Manifest
@@ -7,4 +7,5 @@ EBUILD clang-python-11.1.0.ebuild 925 BLAKE2B db1ed6c8b6f6f156350e4b29ac9292b3a9
EBUILD clang-python-12.0.0.ebuild 925 BLAKE2B db1ed6c8b6f6f156350e4b29ac9292b3a941abaec52a4a41b41f7e3a641cfa2ae9085f356000bfa361fab697299509193b3d20c1300f0514ee72b368daacb382 SHA512 ca8e1aff2ba826ee9c1e7d5cd9d851bf3fa935e429b078a379083be4ef21de0aac62d2efcee9487a4283dd8a81bcfed05ca55116c2b89e8febe45a4af9a30425
EBUILD clang-python-12.0.1.ebuild 927 BLAKE2B 1e0d88215cd7bd7a7968fb00e5c91e10b894750a4ec77a4413d5af19bb93e422b59204e2f62b90ceb628846fede7ed534424640974fe9a3e2d881aec0ccca02e SHA512 11d64eab9433584271e4c97f7af0a9e2762126c3eefffe0f19e74ffdfadef6852aea59337c2fb604daad3c8b3495a3ee2e1a015c20e14eef673e2dacc8304fdf
EBUILD clang-python-13.0.0.9999.ebuild 904 BLAKE2B 22ef0cb9f276007d069b46abebbfbe6b31558f0588280ab48bf693a3d23cf233f6d2f562131f43eb77776445deb5dc25084980c775fa0185cd93d776773ffaf0 SHA512 7f09a06f1c45ac93506aa40ee060104d8df1acbbef4e0852f277d6687cb4c8f9541e6438c6e769c730062570dec51c179539e41a9cdc2d3b492cdd6147733ed3
+EBUILD clang-python-14.0.0.9999.ebuild 904 BLAKE2B 22ef0cb9f276007d069b46abebbfbe6b31558f0588280ab48bf693a3d23cf233f6d2f562131f43eb77776445deb5dc25084980c775fa0185cd93d776773ffaf0 SHA512 7f09a06f1c45ac93506aa40ee060104d8df1acbbef4e0852f277d6687cb4c8f9541e6438c6e769c730062570dec51c179539e41a9cdc2d3b492cdd6147733ed3
MISC metadata.xml 216 BLAKE2B fe5e49887842aa513fbf1f2e09bed09a884d531fd21bdaeb2d389e8bf590b6c0e7063f0af98f66e2db129308ab0f0804ba327c3c752bbb4c900c59ac109d99aa SHA512 3485598147c953e72e1785693a489a7e7d73d59620b76054db9c0ce95d8bfa0e8ffec29da7f7a9d73a32e5b77eac07ca3306c56a972dc57fd89d477edaebf3d5
diff --git a/dev-python/clang-python/clang-python-14.0.0.9999.ebuild b/dev-python/clang-python/clang-python-14.0.0.9999.ebuild
new file mode 100644
index 000000000000..921f7735340a
--- /dev/null
+++ b/dev-python/clang-python/clang-python-14.0.0.9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+inherit llvm.org python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+RDEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+LLVM_COMPONENTS=( clang/bindings/python )
+llvm.org_set_globals
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ python_foreach_impl python_test
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}