summaryrefslogtreecommitdiff
path: root/dev-python/clang-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/clang-python')
-rw-r--r--dev-python/clang-python/Manifest1
-rw-r--r--dev-python/clang-python/clang-python-8.0.9999.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/clang-python/Manifest b/dev-python/clang-python/Manifest
index f42246764106..6ff1e49c65eb 100644
--- a/dev-python/clang-python/Manifest
+++ b/dev-python/clang-python/Manifest
@@ -7,5 +7,6 @@ EBUILD clang-python-5.0.2.ebuild 1079 BLAKE2B deb802fba226c098e138775a71fb5a4926
EBUILD clang-python-6.0.1.ebuild 1097 BLAKE2B c1af92b85dbe2d5060fea49d3352c8151058b8f86c478c347842a1e46255f313a4ad0985b13543e34bba2214f0b17fde35a449779cccf41367a2b1776b6ed130 SHA512 d88877fc98ee9c631d7139e734a87d0a3f998963951602d5e1717b6158b2caaf79fcac4fa699a35131aa58885c3d01a8eb9106183118fc9a4783164e3be1be49
EBUILD clang-python-7.0.1.ebuild 1103 BLAKE2B 880675335893e206636b121e60d025df935a8ac0c08d77c2b9d399f1152e8067f7fa4a95a06487aa51bc5ca53254ec8d661ebaa68c03286e19f1eaa2f26cb6e8 SHA512 a12d2a01febd8cab4e04350e897aeb59865f2a4a891a7aaddfe38f7bb2556595d6e367a9463bd4478b3aa691e41c031e8323c0bc36130c4d96449c0a84999e5c
EBUILD clang-python-7.0.9999.ebuild 1059 BLAKE2B 1ab0d9234fbebea281bf2235f870e6cd468063f2ec5c20f7af3b797e6135aa6730ccea8cbde5ae5993394da1563897f5b45adba1d644257f6bc300b6da5500f9 SHA512 23882089855c9485ccf23129542f3b6a5e891776cf422c9b16a0e534e4084f59d5bfe4526d2510cc094ce8cab311ec141dc76ee45cbee7d43665aaef58c9fec2
+EBUILD clang-python-8.0.9999.ebuild 1056 BLAKE2B 9f18a22421c36ba3796b6fe759e05d5ee5b8ca449e292145c7eda6733c614ffe012f40d0e12ce336ef496a9889463f090fb96180c146975052adc73d8cacd690 SHA512 39239de81290208b734fcd8035a9b8dbc75a0ae9a9cbcfbb7432be5f83b71f2254389ddd139b1c0c9ad59eda86269932a720a02f6dc277ee15178298fbf49a1d
EBUILD clang-python-9999.ebuild 1034 BLAKE2B 3a56c0e391daf98889ba3959f8aa5c944c9930ac482c8beca5f814978507f9869a213384224c6965ade96a3f0b17f83aff9924f07d5ad2d03ed7df8660a54df6 SHA512 bff0eee11762f352ab6616086b19506a2ea0530284f50da24538eb8078d2c04af1d1aa2a8616adecb6bdeab8853728b2f4b5c3133fa15810f00a64855182c486
MISC metadata.xml 216 BLAKE2B fe5e49887842aa513fbf1f2e09bed09a884d531fd21bdaeb2d389e8bf590b6c0e7063f0af98f66e2db129308ab0f0804ba327c3c752bbb4c900c59ac109d99aa SHA512 3485598147c953e72e1785693a489a7e7d73d59620b76054db9c0ce95d8bfa0e8ffec29da7f7a9d73a32e5b77eac07ca3306c56a972dc57fd89d477edaebf3d5
diff --git a/dev-python/clang-python/clang-python-8.0.9999.ebuild b/dev-python/clang-python/clang-python-8.0.9999.ebuild
new file mode 100644
index 000000000000..180856dc03bb
--- /dev/null
+++ b/dev-python/clang-python/clang-python-8.0.9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+inherit git-r3 python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/clang.git
+ https://github.com/llvm-mirror/clang.git"
+EGIT_BRANCH="release_80"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+RDEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}/bindings/python
+
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' bindings/python
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ python_foreach_impl python_test
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}