summaryrefslogtreecommitdiff
path: root/dev-python/clang-python/clang-python-9.0.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/clang-python/clang-python-9.0.0.9999.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-9.0.0.9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/clang-python/clang-python-9.0.0.9999.ebuild b/dev-python/clang-python/clang-python-9.0.0.9999.ebuild
index 70de2ed55129..d1c47b42ebfc 100644
--- a/dev-python/clang-python/clang-python-9.0.0.9999.ebuild
+++ b/dev-python/clang-python/clang-python-9.0.0.9999.ebuild
@@ -9,6 +9,8 @@ inherit git-r3 python-r1
DESCRIPTION="Python bindings for sys-devel/clang"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
+S=${WORKDIR}/${P}/bindings/python
+
EGIT_REPO_URI="https://git.llvm.org/git/clang.git
https://github.com/llvm-mirror/clang.git"
EGIT_BRANCH="release_90"
@@ -17,8 +19,8 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
KEYWORDS=""
IUSE="test"
-RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
# The module is opening libclang.so directly, and doing some blasphemy
# on top of it.
@@ -29,8 +31,6 @@ RDEPEND="
${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
-S=${WORKDIR}/${P}/bindings/python
-
src_unpack() {
git-r3_fetch
git-r3_checkout '' '' '' bindings/python