summaryrefslogtreecommitdiff
path: root/dev-python/clang-python/clang-python-5.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/clang-python/clang-python-5.0.2.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-5.0.2.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/clang-python/clang-python-5.0.2.ebuild b/dev-python/clang-python/clang-python-5.0.2.ebuild
index f60acf5217fa..4331a4a3bf5f 100644
--- a/dev-python/clang-python/clang-python-5.0.2.ebuild
+++ b/dev-python/clang-python/clang-python-5.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -34,8 +34,12 @@ src_unpack() {
tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/bindings/python" || die
}
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}
+
src_test() {
- python_foreach_impl nosetests -v || die
+ python_foreach_impl python_test
}
src_install() {