summaryrefslogtreecommitdiff
path: root/dev-python/clang-python/clang-python-16.0.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/clang-python/clang-python-16.0.0.9999.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-16.0.0.9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/clang-python/clang-python-16.0.0.9999.ebuild b/dev-python/clang-python/clang-python-16.0.0.9999.ebuild
index f0290ca4c7b1..9b34adc8ac6f 100644
--- a/dev-python/clang-python/clang-python-16.0.0.9999.ebuild
+++ b/dev-python/clang-python/clang-python-16.0.0.9999.ebuild
@@ -30,7 +30,7 @@ RDEPEND="
BDEPEND="
${PYTHON_DEPS}
test? (
- sys-devel/clang:${PV%%.*}
+ sys-devel/clang:${LLVM_MAJOR}
)
"
@@ -40,7 +40,7 @@ llvm.org_set_globals
python_test() {
# tests rely on results from a specific clang version, so override
# the search path
- local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${PV%%.*}/$(get_libdir)
+ local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${LLVM_MAJOR}/$(get_libdir)
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}