summaryrefslogtreecommitdiff
path: root/dev-python/clang-python/clang-python-10.0.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/clang-python/clang-python-10.0.0.9999.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-10.0.0.9999.ebuild14
1 files changed, 3 insertions, 11 deletions
diff --git a/dev-python/clang-python/clang-python-10.0.0.9999.ebuild b/dev-python/clang-python/clang-python-10.0.0.9999.ebuild
index 5a65d445f01f..3b6ab496dc37 100644
--- a/dev-python/clang-python/clang-python-10.0.0.9999.ebuild
+++ b/dev-python/clang-python/clang-python-10.0.0.9999.ebuild
@@ -4,15 +4,12 @@
EAPI=7
PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
-inherit git-r3 python-r1
+inherit llvm.org python-r1
DESCRIPTION="Python bindings for sys-devel/clang"
HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-S=${WORKDIR}/${P}/bindings/python
-
-EGIT_REPO_URI="https://git.llvm.org/git/clang.git
- https://github.com/llvm-mirror/clang.git"
+LLVM_COMPONENTS=( clang/bindings/python )
+llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -30,11 +27,6 @@ RDEPEND="
${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
-src_unpack() {
- git-r3_fetch
- git-r3_checkout '' '' '' bindings/python
-}
-
python_test() {
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}