summaryrefslogtreecommitdiff
path: root/dev-python/cherrypy/cherrypy-18.6.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cherrypy/cherrypy-18.6.1.ebuild')
-rw-r--r--dev-python/cherrypy/cherrypy-18.6.1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/cherrypy/cherrypy-18.6.1.ebuild b/dev-python/cherrypy/cherrypy-18.6.1.ebuild
index a039a64ffe1e..d1177e6159ad 100644
--- a/dev-python/cherrypy/cherrypy-18.6.1.ebuild
+++ b/dev-python/cherrypy/cherrypy-18.6.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
MY_P="CherryPy-${PV}"
@@ -40,6 +40,11 @@ BDEPEND="
distutils_enable_tests pytest
python_prepare_all() {
+ local PATCHES=(
+ # https://github.com/cherrypy/cherrypy/pull/1946
+ "${FILESDIR}"/${P}-close-files.patch
+ )
+
sed -r -e '/(pytest-sugar|pytest-cov)/ d' \
-i setup.py || die