summaryrefslogtreecommitdiff
path: root/dev-python/cheetah3/cheetah3-3.2.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cheetah3/cheetah3-3.2.6.ebuild')
-rw-r--r--dev-python/cheetah3/cheetah3-3.2.6.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/cheetah3/cheetah3-3.2.6.ebuild b/dev-python/cheetah3/cheetah3-3.2.6.ebuild
index 750ee0a37321..c4cb900671de 100644
--- a/dev-python/cheetah3/cheetah3-3.2.6.ebuild
+++ b/dev-python/cheetah3/cheetah3-3.2.6.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
+
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Python-powered template engine and code generator"
@@ -22,6 +22,10 @@ BDEPEND="${RDEPEND}"
DOCS=( ANNOUNCE.rst README.rst TODO )
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.10-tests.patch"
+)
+
python_prepare_all() {
# Disable broken tests.
sed \