summaryrefslogtreecommitdiff
path: root/dev-python/charset_normalizer/charset_normalizer-2.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/charset_normalizer/charset_normalizer-2.0.4.ebuild')
-rw-r--r--dev-python/charset_normalizer/charset_normalizer-2.0.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/charset_normalizer/charset_normalizer-2.0.4.ebuild b/dev-python/charset_normalizer/charset_normalizer-2.0.4.ebuild
new file mode 100644
index 000000000000..68c3ead3e5a5
--- /dev/null
+++ b/dev-python/charset_normalizer/charset_normalizer-2.0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="The Real First Universal Charset Detector"
+HOMEPAGE="
+ https://pypi.org/project/charset-normalizer/
+ https://github.com/ousret/charset_normalizer/"
+SRC_URI="
+ https://github.com/Ousret/charset_normalizer/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' setup.cfg || die
+ distutils-r1_src_prepare
+}