summaryrefslogtreecommitdiff
path: root/dev-python/cftime/cftime-1.6.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cftime/cftime-1.6.1.ebuild')
-rw-r--r--dev-python/cftime/cftime-1.6.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/cftime/cftime-1.6.1.ebuild b/dev-python/cftime/cftime-1.6.1.ebuild
new file mode 100644
index 000000000000..5e6beffd8e03
--- /dev/null
+++ b/dev-python/cftime/cftime-1.6.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Time-handling functionality from netcdf4-python"
+HOMEPAGE="https://pypi.org/project/cftime/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND=">=dev-python/numpy-1.13.4[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND=">=dev-python/cython-0.26.2[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pytest-cov dep
+ sed -e "/--cov/d" -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}