summaryrefslogtreecommitdiff
path: root/dev-python/cfn-lint
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest2
-rw-r--r--dev-python/cfn-lint/cfn-lint-1.26.1.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 58926dd26b66..73de7c72b5f0 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,5 +1,7 @@
DIST cfn_lint-1.24.0.tar.gz 2803280 BLAKE2B b859d41231c915c1a06939c75af91da619cc7c3ed7cd95196e0dc708a460e320eaa312197007e54037601db861b5332bdb27d5bae9a5d603171adf492d89968a SHA512 c9d1984671fbcadc659211d74cdc797924d7a0cffe3baaa284438831fca61b53adfcc615b93e23e946058a9ffc278cc5c088e5c24f2745035f32e9f6cdae24be
DIST cfn_lint-1.25.1.tar.gz 2837233 BLAKE2B 0779afe85f8cc1190f24fb9531c576b61a2921be1e725289c164c5113cfffeca6ad984832c0efa10cb6e7dbb78515b24fea3dbb5da3ef4b63765ed80eb1294af SHA512 f623dc24d3a6e3425e9c764498c874afcbc9406a31d8aa4f2c1a0a14e3dd4446584a0524d5a6d016bdcc95810907418b7dda9883d80d9ff2f3ae9385453d428a
+DIST cfn_lint-1.26.1.tar.gz 2943127 BLAKE2B ca87cf05d0b5ed3774c6c216f856c057bc04b9353f41feb4b1090c7d809685dc65057dab9b1b121fda78488c55bc8da2b3303a25a5047340843723a2e5d3849a SHA512 a8c14275188d64e7ff53d5dd798805a69cf3fc4b13ca9cce19775cd4033b0a0a5815efb9f6900ed8d4116c8877ce62117738098d500373ae6ba3984fe4170ff1
EBUILD cfn-lint-1.24.0.ebuild 2173 BLAKE2B c38787bdd2b850b0cf2c02a4c4f573926d67677a8529d356bf1d8d6912fffc4c16f3364361175fc7c6f4f67ebc306e94492412ff96a58bfa41356f3273966cdd SHA512 7a46fb2c6f247507fb39b12d1e4c726f8584f3ee1b7a57e8f926e3208fb653667f62ca3ad1482065d5b338f5468df6b3a36efbf07ae2cd442456ade0cf3b0c58
EBUILD cfn-lint-1.25.1.ebuild 2176 BLAKE2B 5a8d1aff8959104114cce624b38fb1cd77a19f890f444f747a5e79e2925b933e4454c06b4580669c8b91b71a352f3b083b981a362ea41e8c8908cbdcaba0f9e5 SHA512 da493f200f8720b8d5b9f73ca41f5d959497cac8e62e9889493d378ad5d8ea40e35cf5414e748a82a351f6b46581f8a8df34508fb67f6fa14309975cedaf5424
+EBUILD cfn-lint-1.26.1.ebuild 2176 BLAKE2B 5a8d1aff8959104114cce624b38fb1cd77a19f890f444f747a5e79e2925b933e4454c06b4580669c8b91b71a352f3b083b981a362ea41e8c8908cbdcaba0f9e5 SHA512 da493f200f8720b8d5b9f73ca41f5d959497cac8e62e9889493d378ad5d8ea40e35cf5414e748a82a351f6b46581f8a8df34508fb67f6fa14309975cedaf5424
MISC metadata.xml 478 BLAKE2B 79b8a28c1df2fd10729d91d38794aed81db55cbfba57be5999163d2daffa66e8558b71af1b282e3ce059374605ca51b4e367a4f027cbab8caad628610c48bd59 SHA512 b77b106f37ef48af4c9acc81a935b2780156f32017d23becab65aadfe3cb930986186775a8f129b6d997b0b6171ede2906ce1080d44fa87e7533a06621eeb85c
diff --git a/dev-python/cfn-lint/cfn-lint-1.26.1.ebuild b/dev-python/cfn-lint/cfn-lint-1.26.1.ebuild
new file mode 100644
index 000000000000..11b35b918d51
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-1.26.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.94.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ # different graphviz version?
+ test/unit/module/template/test_template.py::TestTemplate::test_build_graph
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}