summaryrefslogtreecommitdiff
path: root/dev-python/cchardet/cchardet-2.1.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cchardet/cchardet-2.1.7.ebuild')
-rw-r--r--dev-python/cchardet/cchardet-2.1.7.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/cchardet/cchardet-2.1.7.ebuild b/dev-python/cchardet/cchardet-2.1.7.ebuild
new file mode 100644
index 000000000000..76ade5a80603
--- /dev/null
+++ b/dev-python/cchardet/cchardet-2.1.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="High speed universal character encoding detector"
+HOMEPAGE="https://github.com/PyYoshi/cChardet https://pypi.org/project/cchardet/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${PYTHON}" setup.py nosetests || die "tests failed with ${EPYTHON}"
+}