summaryrefslogtreecommitdiff
path: root/dev-python/caldav/caldav-0.11.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/caldav/caldav-0.11.0.ebuild')
-rw-r--r--dev-python/caldav/caldav-0.11.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/caldav/caldav-0.11.0.ebuild b/dev-python/caldav/caldav-0.11.0.ebuild
new file mode 100644
index 000000000000..de90382f0920
--- /dev/null
+++ b/dev-python/caldav/caldav-0.11.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="CalDAV (RFC4791) client library for Python"
+HOMEPAGE="
+ https://github.com/python-caldav/caldav
+ https://pypi.org/project/caldav/
+"
+SRC_URI="
+ https://github.com/python-caldav/caldav/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( GPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/vobject[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ www-apps/radicale[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # needs unpackaged recurring_ical_events
+ tests/test_caldav.py::TestLocalRadicale::testTodoDatesearch
+ tests/test_caldav.py::TestLocalRadicale::testRecurringDateSearch
+ tests/test_caldav_unit.py::TestExpandRRule::testZero
+ tests/test_caldav_unit.py::TestExpandRRule::testOne
+ tests/test_caldav_unit.py::TestExpandRRule::testThree
+ tests/test_caldav_unit.py::TestExpandRRule::testSplit
+)