summaryrefslogtreecommitdiff
path: root/dev-python/build
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/build')
-rw-r--r--dev-python/build/Manifest2
-rw-r--r--dev-python/build/build-1.2.1.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/build/Manifest b/dev-python/build/Manifest
index 2413ab550763..c0ab2fe07d0d 100644
--- a/dev-python/build/Manifest
+++ b/dev-python/build/Manifest
@@ -1,5 +1,7 @@
DIST build-1.1.1.gh.tar.gz 44605 BLAKE2B aa1d554d55007e8cb715981938bb8765230ae5ddc6c5bc29efeb52c0e18b6337a13c27f3389772a83cc0ecc9b7d3e889fbc305e91f1290424d7031a1782f683f SHA512 5fa64b07f2c22faca074d1447f5fcb12b7ad40e5fe897f034901d7932d8a9aa2c1dfa806d373503246255d7d9a2429b336384a980376f4ae7c810ae275b735da
DIST build-1.2.0.gh.tar.gz 47350 BLAKE2B 874f4871d5b8c22ce1d93a840fd00315cfa3a93b01a44e3c8c3270d2dcb66455e2c44e757d0ae15a58a35ea4ee8679a797191523254c914150d801cf3c0a5fa8 SHA512 aaa4677f8eb04c2872dc0f64287e00cd0aa47b10d3bfd67a63c22db42caef8baae9996c3a6ced3a07cce4a54d6fd52a3f15d167f804f7f518d258aa5da68419c
+DIST build-1.2.1.gh.tar.gz 47394 BLAKE2B d38a138dee5065ff0faee453bdc608fc519bc4b4a3cec8b60cf4f745288f8238dd7e9334f75bdd67765037a62b220079ce924c6581f745eb3750e732b2184d48 SHA512 77003e16d3776c3a4be920251bf14650eea112b92d94116cb1893195b8e16aae57321206ae63267119247f2794f220c891b7d913e07a8258b313d34c07d54fe9
EBUILD build-1.1.1.ebuild 1684 BLAKE2B 0dfc43a98f0edb7693d533cd3b75570191e716e87ce00e1255f2d1a3d40fa06bc028f1895535e8eac7f38b0d3c95da057ae9e93cef1eb763043a471441bea5e7 SHA512 b65bacfcde9bc791b724a9e3d461a1398b206117bea5f3aabbfc5ea96c174ba56979903adde1d10734939685b45c2bf91b832036c21e7220186c38173fded8c1
EBUILD build-1.2.0.ebuild 2148 BLAKE2B 5175758b124efc8e6533f47522e00dc72aaf2e10277d4b2c214fea018185fb8e0b7ceeeb2e9efb6963c04bd490df9d7e97715c1a6457dc96cf5ba3367f08075d SHA512 996ff891f39b4d0ce799b378b8639e54db071216ea046fe780d552683e90b5482165fea575509dbc5e1cc651af32d2bdb0f8a7962b3412c362bddcc239a7c5f2
+EBUILD build-1.2.1.ebuild 2184 BLAKE2B c48fde5f0ada32df1e08a9b5ca870872b0d3a894779ba2acbeece362685f9c06f1a243ce69e44e411d3606d388cd510e0feea92f00a802db66e5c5d520ea51a5 SHA512 59c48c70e695b4f345acc185207971cedaba22100da0b92b5e4793f08ff6405addc8f69e77618f682b63856ff64e961d962cbbc0c1817a1a83427d29a4bcd069
MISC metadata.xml 361 BLAKE2B 1c46e1d83bec4a8aaedd932af700865009735ff75e3af63ef7c08f7c00883d5f658f86aec981cd48c8ef0ab0a287250a3a4fdfad42fb434f6c06d9f33f72f7d6 SHA512 89c86db40833c86e25f387c5bfa8952b62e983714be85af1e8ca2a6ef8a402b94cc32dfc18cda8d8850736aaabdb46c153743af9bcb027e86b2c1f085f6f2369
diff --git a/dev-python/build/build-1.2.1.ebuild b/dev-python/build/build-1.2.1.ebuild
new file mode 100644
index 000000000000..c50be1f5770d
--- /dev/null
+++ b/dev-python/build/build-1.2.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple, correct PEP517 package builder"
+HOMEPAGE="
+ https://pypi.org/project/build/
+ https://github.com/pypa/build/
+"
+SRC_URI="
+ https://github.com/pypa/build/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc64 ~sparc"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/packaging-19.1[${PYTHON_USEDEP}]
+ dev-python/pyproject-hooks[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/filelock-3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-rerunfailures-9.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.34[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-56.0.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.0.35[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.36.0[${PYTHON_USEDEP}]
+ test-rust? (
+ !sparc? ( dev-python/uv )
+ )
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken by the presence of flit_core
+ tests/test_util.py::test_wheel_metadata_isolation
+ # broken by the presence of virtualenv (it changes the error
+ # messages, sic!)
+ 'tests/test_main.py::test_output[via-sdist-isolation]'
+ 'tests/test_main.py::test_output[wheel-direct-isolation]'
+ # broken when built in not normal tty on coloring
+ tests/test_main.py::test_colors
+ 'tests/test_main.py::test_output_env_subprocess_error[color]'
+ # Internet
+ 'tests/test_main.py::test_verbose_output[False-0]'
+ 'tests/test_main.py::test_verbose_output[False-1]'
+ # broken by uv being installed outside venv
+ tests/test_env.py::test_external_uv_detection_success
+ )
+
+ if ! has_version "dev-python/uv"; then
+ EPYTEST_DESELECT+=(
+ tests/test_env.py::test_uv_impl_install_cmd_well_formed
+ 'tests/test_env.py::test_venv_creation[uv-venv+uv-None]'
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m "not network" -p pytest_mock -p rerunfailures
+}