summaryrefslogtreecommitdiff
path: root/dev-python/brython
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/brython')
-rw-r--r--dev-python/brython/Manifest2
-rw-r--r--dev-python/brython/brython-3.7.4.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/brython/Manifest b/dev-python/brython/Manifest
index 53269dd091f6..8ca09c6a4fbd 100644
--- a/dev-python/brython/Manifest
+++ b/dev-python/brython/Manifest
@@ -1,3 +1,5 @@
DIST brython-3.7.3.tar.gz 10403156 BLAKE2B a30c957925149f1b7eb736c1fcacd171dffb5846f6a343227596e759820c794c265befbb04137e797c1eabe8d9f0a3faa93fe425e4b0c13fda4c78b4c4bb1ecd SHA512 f234c7bc67d935e5bd5bfa8e473bccf90245ab4dabccd363bc5e9e01e1c9ea9d95989c5f8b323c158e286ac4a66106eb07722d1fcc82353ad036e35b4fda5669
+DIST brython-3.7.4.tar.gz 10473351 BLAKE2B c457498d7f9b61ef416d6ec0ccbf86e3fdc7cc55f90fd8a853005285cab814d054319a5437cc24d22d6088af6f5b58da5311c6f68721d7b243fe31ef450c38a1 SHA512 70959debdd0a3e7f7e533f17aa2149802454bee23598d844156756ee6aab697b75337a26a341e6408966036f419696d0f8b073cb5383f32a9f6de65cde2fa40a
EBUILD brython-3.7.3.ebuild 761 BLAKE2B 35236dc8fac0d6f47e8cd45855538098cd50bc2de66467c552c55885237264913dab68a18671b0a83973c9716e5155fee029f7201863178a56ce889713fcec8a SHA512 ff84dbf08200f19b806d9e109772d7318dfb32fba4e1643023621af992f798e3eafcb1f6a676e5a2b982efe82630bfac73b3406ec051d5c365c96182100a3049
+EBUILD brython-3.7.4.ebuild 761 BLAKE2B 35236dc8fac0d6f47e8cd45855538098cd50bc2de66467c552c55885237264913dab68a18671b0a83973c9716e5155fee029f7201863178a56ce889713fcec8a SHA512 ff84dbf08200f19b806d9e109772d7318dfb32fba4e1643023621af992f798e3eafcb1f6a676e5a2b982efe82630bfac73b3406ec051d5c365c96182100a3049
MISC metadata.xml 345 BLAKE2B ab7c78390c35a156fed3a3507ab979347fef95259f4083a28ba2c925356907158a0e7249cc4e6e46cc9117e418a07a3f91a67ba34163aa5be657ca37bf11b318 SHA512 ff1357bc421a8f96fe10ddc253035271616da444fb6cca11d3b263629c12abfbfc17324d06e744c95c319fe525763ff752db69aa3439edaa3fdc3e7e56c5bb05
diff --git a/dev-python/brython/brython-3.7.4.ebuild b/dev-python/brython/brython-3.7.4.ebuild
new file mode 100644
index 000000000000..ce838901b946
--- /dev/null
+++ b/dev-python/brython/brython-3.7.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit webapp python-single-r1
+
+DESCRIPTION="A Python 3 implementation for client-side web programming"
+HOMEPAGE="http://www.brython.info"
+SRC_URI="https://github.com/${PN}-dev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ dodoc LICENCE.txt README.md
+ rm -v LICENCE.txt README.md bower.json .{git*,tra*} server.py || die
+
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_src_install
+}