summaryrefslogtreecommitdiff
path: root/dev-python/botocore
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest2
-rw-r--r--dev-python/botocore/botocore-1.34.128.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 6d608f869989..03ddf2a6af89 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,7 +1,9 @@
DIST botocore-1.34.117.gh.tar.gz 13076178 BLAKE2B defbd66d6409004fe49df44aec0a00b4bbe1a459d3e4b067c5c8609b998c63e7d62c8d3c48805416d44c08aeb3ab261f4449cc7e6a7c66dd3ca5f97bdcce291f SHA512 d9736ddb868e602afbaad95989d284b2835636f273e8a4263caa7eec619fe7cc45515fbbe98d4fd33121fe0d97d34353f7cd811bc878a81d1f5f7437798b24d6
DIST botocore-1.34.122.gh.tar.gz 13066937 BLAKE2B f22af79873b5574ae4b2b9041568cfc1d727625c3fa45c9b8d1bef71ffcce893aa8a3591c83160437c7e617be72814a2209569db633d857f869a2152af7c8e05 SHA512 f08dcb2920d4bd26a47478edb871f75b240275a7b96acf58be838080dddca3d4f64b9fda8683e5a3db97defe367298b2ba634fc4d605523805b23c83c3a5ae0d
DIST botocore-1.34.127.gh.tar.gz 13112261 BLAKE2B e883f0a1e29178667678132195aea9666a124456e731e1b158eed895c125fd614e5671639766f7ad46c2e6b16c4156ff5e42594bc04e49bf25380c91cfcbe264 SHA512 48ca2179c24bb219202e5029dd62350a6fc5c64707762f0f33282e542dbc2227bb146376afa9e6b9eb1e45e3c801208a142bef4827d5036eb4724299c826d534
+DIST botocore-1.34.128.gh.tar.gz 13115625 BLAKE2B 77be2cb79722d1052b64df55a7bb7a9d43dc7d0052c2a4ce18265745edb7b6f9f30780a98f2395abadcfc16817e7375b182691b51f44450574846cc4bb423df5 SHA512 d5f709230ba73ea7c78a4b55a07c0d834b1abf2c3196d43d47d042e1cb190f5d8d08ad942053963ad5df9b2e01b5f905d167840f54842a41181de5305762d5d1
EBUILD botocore-1.34.117.ebuild 1477 BLAKE2B 784b43f060f0702808a3894fdab7a15dd4b4feeffc3c1ab2fe24cca762b2dc1310f40ae5b2941db5c4aa9c4ff8b69d858520826027a50ce975d25150132b4d56 SHA512 e86970ec900929641794d61e02f26bc7e7c8af803095dcc5c8fbedac9d79275c596176f2b492061289056c7d29ebbaa6e64344148f22b6349ac4420ab5038dca
EBUILD botocore-1.34.122.ebuild 1484 BLAKE2B 30f7e11da3d7c36574e721023e7a0dba6ffe87172afec095dec711b929274a58d6a1352d131df44cd36598f11dda34df8d2e51e723b62e8ac096437360526aa6 SHA512 699735f1b1feb67c3b03d3e3787b45bfa3bc2ac6f639881b9414cdfc4aea5bb022d2e701d09061de5a237dcf3f32be4668b7ebc3f12cd950765b439d1ea4d88c
EBUILD botocore-1.34.127.ebuild 1484 BLAKE2B 30f7e11da3d7c36574e721023e7a0dba6ffe87172afec095dec711b929274a58d6a1352d131df44cd36598f11dda34df8d2e51e723b62e8ac096437360526aa6 SHA512 699735f1b1feb67c3b03d3e3787b45bfa3bc2ac6f639881b9414cdfc4aea5bb022d2e701d09061de5a237dcf3f32be4668b7ebc3f12cd950765b439d1ea4d88c
+EBUILD botocore-1.34.128.ebuild 1484 BLAKE2B 30f7e11da3d7c36574e721023e7a0dba6ffe87172afec095dec711b929274a58d6a1352d131df44cd36598f11dda34df8d2e51e723b62e8ac096437360526aa6 SHA512 699735f1b1feb67c3b03d3e3787b45bfa3bc2ac6f639881b9414cdfc4aea5bb022d2e701d09061de5a237dcf3f32be4668b7ebc3f12cd950765b439d1ea4d88c
MISC metadata.xml 499 BLAKE2B e5aaa7da26f200c09adfdf38b68f656bbccbec627cb5d966b280ac2165334e7eec659c89075bcace748f58e2ec3e7d2998e54a688d56ecea2d30653c67dfd35a SHA512 103c554d5dbd967bf9b6e418b3913d9235e7e910d012160909ce0715134ed2e37b06e6a345395f9d16ce08d1cf51f3ce458bce93c6a978fd3dca6610f2acdbd0
diff --git a/dev-python/botocore/botocore-1.34.128.ebuild b/dev-python/botocore/botocore-1.34.128.ebuild
new file mode 100644
index 000000000000..ba6cd2a5d2a2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.128.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}