summaryrefslogtreecommitdiff
path: root/dev-python/boto3
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest2
-rw-r--r--dev-python/boto3/boto3-1.37.10.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index e1b3bcd44b16..30e703638fd2 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,7 +1,9 @@
DIST boto3-1.36.26.gh.tar.gz 903988 BLAKE2B f9bb945e9132a7af7bd92ff48e5a99cc89488283c30e2d7d0cbb22d9002bd41c5d5f8a449494d2aa4758648aca3c2e88dad8bebda640af4bba7df64e72ffd2bc SHA512 77a545fd94ed50114db72d7b763e232356e78cda7a2780c12c26b602ed85101218339adf6247ba45e3a8b16c33fb11f5fb34572a37dfeac43dd9322823372cc1
+DIST boto3-1.37.10.gh.tar.gz 912397 BLAKE2B fbd9fa118a936901c9cef6739bd114d69464d7f7d8211a42370ed7235637bd09c966c12a36c4faee2d4c3b8b58a179f6b20ee88723a881de8e03daed687ca76e SHA512 1788b0e75b93e6a8c56e8f63cdcb39b5075d2746fcebc04f1842915d849b7976cb1ad537f913ee78405982d2527b49dd17a1781f51a75d9c731ba78d249e1eb6
DIST boto3-1.37.4.gh.tar.gz 908620 BLAKE2B ed63365ccd6da9b97715e4110be2b562285a123139a90ddb10c1411d5bd5ba0de9c110177a31f03ecb7e257fd79a0de89a8be97493a83f3207050676f7022e04 SHA512 dbf40cb809ee1d3ef352b97f62c111d113293211226a63298979d8ea14833c83ac2e321714dac349bfe095f75120c2752d08a01c19e51d9b0fc947e27a910005
DIST boto3-1.37.9.gh.tar.gz 911836 BLAKE2B d190525b9c5e39b445042aba6d8e57da5e49165775901ceebe44b76fd2780ec85a2f5a8a08d3a9a5e451d42bbae19b679e565a7a9acc663258ea0b7909a9a798 SHA512 12cba48d5f2c158b372eaf4e44903e22ca963e5712c3c463fbfd20626a771efe30530852b6c9ab70132a26472ff1b4656095675a5de37524f6b489c25175f8fe
EBUILD boto3-1.36.26.ebuild 1205 BLAKE2B ba88d00e8ea05d27260511e6110158d1f305ce8bde0aaf3385814b38f6b977bd8fae2b092659d5765d6c3bcf80cd75fe5f2bea95374a3105c23cdfbf04bd8ec8 SHA512 6cf3155f855f19611a770cf2db452b139af4869a39f2e07d1040a9c45a3cfd13341f3a7eadb2e13da7c38d29492d68307a9e88b62c22704ef15a5c082da651fd
+EBUILD boto3-1.37.10.ebuild 1212 BLAKE2B fecfa738c561d1cc8851eef482992a276efc114e47fad372693f9e6896da4b9636b04990a1be9de221d95361e34e35026ec52d234093788354b9c2a1a10e1be1 SHA512 27684bfc9dd8f7d85b5b0dbd879fbe742454c3cd6ebe86666e3214822f42aa4f7cb4e00752aa6baacadfa2b2cb9a1d358e158ea136a6ef62acf36c9fe178ae12
EBUILD boto3-1.37.4.ebuild 1212 BLAKE2B fecfa738c561d1cc8851eef482992a276efc114e47fad372693f9e6896da4b9636b04990a1be9de221d95361e34e35026ec52d234093788354b9c2a1a10e1be1 SHA512 27684bfc9dd8f7d85b5b0dbd879fbe742454c3cd6ebe86666e3214822f42aa4f7cb4e00752aa6baacadfa2b2cb9a1d358e158ea136a6ef62acf36c9fe178ae12
EBUILD boto3-1.37.9.ebuild 1212 BLAKE2B fecfa738c561d1cc8851eef482992a276efc114e47fad372693f9e6896da4b9636b04990a1be9de221d95361e34e35026ec52d234093788354b9c2a1a10e1be1 SHA512 27684bfc9dd8f7d85b5b0dbd879fbe742454c3cd6ebe86666e3214822f42aa4f7cb4e00752aa6baacadfa2b2cb9a1d358e158ea136a6ef62acf36c9fe178ae12
MISC metadata.xml 493 BLAKE2B 7d6324fc877ffe1d20c5369c2af0b09a7028f94d28f1841188913d0d8be7ea699c9d3f92c624992c4c96bd69615d3a1211a2483c76c56b7d3082492e43512523 SHA512 44420d8c03d5986f990b76369edfa8dfd7659b4952db3ad946fd05392ec594628a28745ad888d055d4f074d5214f61fcffafe6c04c4ab54109d45ac0371582bd
diff --git a/dev-python/boto3/boto3-1.37.10.ebuild b/dev-python/boto3/boto3-1.37.10.ebuild
new file mode 100644
index 000000000000..b087a88814e8
--- /dev/null
+++ b/dev-python/boto3/boto3-1.37.10.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.11.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}