summaryrefslogtreecommitdiff
path: root/dev-python/blosc/files/blosc-1.10.0-unbundle.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/blosc/files/blosc-1.10.0-unbundle.patch')
-rw-r--r--dev-python/blosc/files/blosc-1.10.0-unbundle.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/blosc/files/blosc-1.10.0-unbundle.patch b/dev-python/blosc/files/blosc-1.10.0-unbundle.patch
new file mode 100644
index 000000000000..0ea6740f9c07
--- /dev/null
+++ b/dev-python/blosc/files/blosc-1.10.0-unbundle.patch
@@ -0,0 +1,38 @@
+From b2935461d889eac99fa1bdfb04a96f1c3a23c4c3 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Thu, 24 Dec 2020 01:06:23 +0100
+Subject: [PATCH] build against system blosc
+
+---
+ blosc/CMakeLists.txt | 14 ++------------
+ 1 file changed, 2 insertions(+), 12 deletions(-)
+
+diff --git a/blosc/CMakeLists.txt b/blosc/CMakeLists.txt
+index 7f06f28..fcf7db0 100644
+--- a/blosc/CMakeLists.txt
++++ b/blosc/CMakeLists.txt
+@@ -1,19 +1,9 @@
+ # Todo: c-blosc provides a CMake package configuration file that we can build
+ # against if blosc is available on the system, etc.
+-# find_package(blosc)
+-# if(NOT blosc_FOUND)
+-set(BUILD_STATIC ON CACHE BOOL "Build a static version of the blosc library.")
+-set(BUILD_SHARED ON CACHE BOOL "Build a shared library version of the blosc library.")
+-set(BUILD_TESTS OFF CACHE BOOL "Build test programs form the blosc compression library")
+-set(BUILD_BENCHMARKS OFF CACHE BOOL "Build benchmark programs form the blosc compression library")
+-set(BLOSC_IS_SUBPROJECT OFF CACHE BOOL "Blosc is subproject")
+-set(CMAKE_POSITION_INDEPENDENT_CODE ON)
+-add_subdirectory(c-blosc)
+-include_directories("${CMAKE_CURRENT_SOURCE_DIR}/c-blosc/blosc")
+-
++find_package(blosc)
+
+ add_library(blosc_extension MODULE blosc_extension.c)
+-target_link_libraries(blosc_extension blosc_static)
++target_link_libraries(blosc_extension blosc)
+ python_extension_module(blosc_extension)
+
+ add_custom_command(
+--
+2.29.2
+