summaryrefslogtreecommitdiff
path: root/dev-python/bleach/bleach-3.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bleach/bleach-3.3.0.ebuild')
-rw-r--r--dev-python/bleach/bleach-3.3.0.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/bleach/bleach-3.3.0.ebuild b/dev-python/bleach/bleach-3.3.0.ebuild
deleted file mode 100644
index f15173747b0e..000000000000
--- a/dev-python/bleach/bleach-3.3.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="an easy whitelist-based HTML-sanitizing tool"
-HOMEPAGE="https://github.com/mozilla/bleach https://pypi.org/project/bleach/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/html5lib-1.0.1-r1[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/webencodings[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/bleach-3.2.1-py39.patch
-)
-
-src_prepare() {
- # unbundle unpatched broken html5lib
- rm -r bleach/_vendor || die
- sed -i -e 's:bleach\._vendor\.::' \
- bleach/html5lib_shim.py \
- bleach/sanitizer.py \
- tests/test_clean.py || die
-
- distutils-r1_src_prepare
-}