summaryrefslogtreecommitdiff
path: root/dev-python/beautifulsoup4/beautifulsoup4-4.12.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/beautifulsoup4/beautifulsoup4-4.12.1.ebuild')
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.12.1.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/beautifulsoup4/beautifulsoup4-4.12.1.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.12.1.ebuild
deleted file mode 100644
index 179ee52155fd..000000000000
--- a/dev-python/beautifulsoup4/beautifulsoup4-4.12.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
-HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/soupsieve-1.3[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
-"
-# bs4 prefers cchardet > chardet > charset-normalizer
-# however, charset-normalizer causes test failures, so force the other two
-# dev-python/chardet[${PYTHON_USEDEP}]
-BDEPEND="
- test? (
- || (
- dev-python/cchardet[${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
- )
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx doc/source