summaryrefslogtreecommitdiff
path: root/dev-python/bandit
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bandit')
-rw-r--r--dev-python/bandit/Manifest2
-rw-r--r--dev-python/bandit/bandit-1.7.10.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/bandit/Manifest b/dev-python/bandit/Manifest
index 72042d483f27..72f2e8efb339 100644
--- a/dev-python/bandit/Manifest
+++ b/dev-python/bandit/Manifest
@@ -1,3 +1,5 @@
+DIST bandit-1.7.10.tar.gz 4228540 BLAKE2B ca1fdbd5061a635520500cb583b739d19335920eeb89661c7ddf2a2c3a97d3c55c2ce7797be984dd1dba2613a38d6b2e0bbcfde655f9d4ed76582ce831e4b42e SHA512 c9c5d098186a23f856f4bdecdebfe863f7ddce8627608b80c62a537416d2aa91666a95c304f5cdde43ff1a41e1f6a58b30dce1042159a1ea74b8b5c9a8ee381a
DIST bandit-1.7.9.tar.gz 4225771 BLAKE2B e5d20fbf4c3a33b092c23ad356dad39543ccea4d552687b97350cb6fe960dfa004cbef627ee0e0911da147ed53c6eb57046ec57c76858c58e772bf81e2c2b82e SHA512 a71e3eb359fad952afc9e210795fb8cc6fe178305bb837e002af83eccc4a958664b69422ba93d7d72b24089ba3142667ca17909d712db1b447e78d6f7f4c9634
+EBUILD bandit-1.7.10.ebuild 1182 BLAKE2B 0c2798662b0b9b0b0223b8b15fd4c1a28ae76bce5b77e2fcbec35fab5b9152e185c74ae57492456443ed701fa3db042b838892430b01f9cc53fda0a359934de4 SHA512 e7fb100e3b4d87d7e4229af61c7768a6e0fc6307a6382824d6386e72b0f6b1ec03bba7e34b439d1fea33f0fb6d48cfbf6707b2a5fbf8f6b2272c23fc3cce07e2
EBUILD bandit-1.7.9.ebuild 1179 BLAKE2B 34faa8a64ad99f56da78e25a9a49e6ddc104802b268db7d4bde0fc3f0df33d4173c971605be42e2776dd9b4e486bb763a0154b7c6866f68ed7c0639356f43931 SHA512 1aa68f206cf7964f640c6b6ae9bf45c610e39eab2b13a93fe1dcff1ebdba97d820980e55f3940971670f7b1e32b62e5ef6385713b13715dd2255af6b77eafe3b
MISC metadata.xml 810 BLAKE2B 6f836d0afbb33f233618f056a9d4161cbdafe93abbed2f321e4e799bb75a86e2c4cc27cd43e74d05e1a15496ecf52e6a575ecd8dd4ae463ee37f742331b0086d SHA512 e3dc0280839cb1a54a2585fd6fe19fce66ceff73a7e010479e99e9631c224851b303d577b5de0ba62bc94b78b9b75b30c0103421441bba9753e4231bc3914481
diff --git a/dev-python/bandit/bandit-1.7.10.ebuild b/dev-python/bandit/bandit-1.7.10.ebuild
new file mode 100644
index 000000000000..608a06da92cc
--- /dev/null
+++ b/dev-python/bandit/bandit-1.7.10.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A security linter from OpenStack Security"
+HOMEPAGE="
+ https://github.com/PyCQA/bandit/
+ https://pypi.org/project/bandit/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/GitPython-3.1.30[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/beautifulsoup4-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.9.4[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.3.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+ )
+"
+
+distutils_enable_tests unittest