summaryrefslogtreecommitdiff
path: root/dev-python/backoff/backoff-1.11.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/backoff/backoff-1.11.0.ebuild')
-rw-r--r--dev-python/backoff/backoff-1.11.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/backoff/backoff-1.11.0.ebuild b/dev-python/backoff/backoff-1.11.0.ebuild
new file mode 100644
index 000000000000..50f63c524f6b
--- /dev/null
+++ b/dev-python/backoff/backoff-1.11.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Function decoration for backoff and retry"
+HOMEPAGE="https://github.com/litl/backoff https://pypi.org/project/backoff/"
+SRC_URI="https://github.com/litl/backoff/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+DOCS=( README.rst )
+
+BDEPEND="test? ( dev-python/pytest-asyncio[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest