summaryrefslogtreecommitdiff
path: root/dev-python/autopage
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/autopage')
-rw-r--r--dev-python/autopage/Manifest3
-rw-r--r--dev-python/autopage/autopage-0.4.0.ebuild32
-rw-r--r--dev-python/autopage/metadata.xml13
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/autopage/Manifest b/dev-python/autopage/Manifest
new file mode 100644
index 000000000000..47480eaffe1d
--- /dev/null
+++ b/dev-python/autopage/Manifest
@@ -0,0 +1,3 @@
+DIST autopage-0.4.0.gh.tar.gz 14809 BLAKE2B 8b91d76c04f3b6519fe2660cbebb50c9b767346b6313303b757b04bea8e7eb8a48aaeaabe364b1b18cadbd5125c95f77b187f779ef83c913e8db13ca88284311 SHA512 a7573dc5d62559f06b54b4b40ffa916209ab7c3348ac7b0cb20ae840fe841e8f8efab1c1853196b4cad0ce5fbc52b679e651f76f7023af960dd8cc876a6d1f14
+EBUILD autopage-0.4.0.ebuild 717 BLAKE2B 3752a1813c132422362aa730bc99fa72eade28a31a60271152363571cc614cc3cc4d83d169adea93317b8139d185ffc4b3840838bd281f6c7f63ed7adb7cc93f SHA512 bd2ef8f590a966ec76638af1d018f92bb2891f74762b4fddc9aee7f0807ab6b0582d2e7b6acfd12e674c32e50a8d4009eac00f36a8b7ccb85455062a30fe1af6
+MISC metadata.xml 389 BLAKE2B bc7cc854b37e32846dd44600f748dabc75718dae5e548db799ba3a235ef2d39257c15f0455603a0c161666b01fcbc3c0b136b36204fcef2a0ca6117d74356166 SHA512 53a90e5e7d03679e3472225db8347fa582e42990ce217521f67d8eabe8a171bc192c152dfbab41f66ed3214033263a56d29b3f302ee4b86826e55f963799c3f0
diff --git a/dev-python/autopage/autopage-0.4.0.ebuild b/dev-python/autopage/autopage-0.4.0.ebuild
new file mode 100644
index 000000000000..9dbdbd627e42
--- /dev/null
+++ b/dev-python/autopage/autopage-0.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# TODO: teach the eclass that we don't need pp2sp for simple setuptools?
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to provide automatic paging for console output"
+HOMEPAGE="
+ https://pypi.org/project/autopage/
+ https://github.com/zaneb/autopage/"
+SRC_URI="
+ https://github.com/zaneb/autopage/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? ( dev-python/fixtures[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests unittest
+
+python_test() {
+ unset LESS PAGER
+ eunittest
+}
diff --git a/dev-python/autopage/metadata.xml b/dev-python/autopage/metadata.xml
new file mode 100644
index 000000000000..c168437bcf85
--- /dev/null
+++ b/dev-python/autopage/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">zaneb/autopage</remote-id>
+ <remote-id type="pypi">autopage</remote-id>
+ </upstream>
+</pkgmetadata>