summaryrefslogtreecommitdiff
path: root/dev-python/asyncstdlib/asyncstdlib-3.9.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/asyncstdlib/asyncstdlib-3.9.1.ebuild')
-rw-r--r--dev-python/asyncstdlib/asyncstdlib-3.9.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/asyncstdlib/asyncstdlib-3.9.1.ebuild b/dev-python/asyncstdlib/asyncstdlib-3.9.1.ebuild
new file mode 100644
index 000000000000..0c31c6e1105c
--- /dev/null
+++ b/dev-python/asyncstdlib/asyncstdlib-3.9.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="The missing async toolbox"
+HOMEPAGE="
+ https://github.com/maxfischer2781/asyncstdlib/
+ https://pypi.org/project/asyncstdlib/"
+SRC_URI="
+ https://github.com/maxfischer2781/asyncstdlib/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest