summaryrefslogtreecommitdiff
path: root/dev-python/asttokens/asttokens-2.0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/asttokens/asttokens-2.0.7.ebuild')
-rw-r--r--dev-python/asttokens/asttokens-2.0.7.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/asttokens/asttokens-2.0.7.ebuild b/dev-python/asttokens/asttokens-2.0.7.ebuild
new file mode 100644
index 000000000000..839fb416705f
--- /dev/null
+++ b/dev-python/asttokens/asttokens-2.0.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Annotate Python AST trees with source text and token information"
+HOMEPAGE="
+ https://github.com/gristlabs/asttokens/
+ https://pypi.org/project/asttokens/
+"
+SRC_URI="
+ https://github.com/gristlabs/asttokens/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/astroid[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # test suite itself broken with new astroid versions, upstream less care
+ # https://github.com/gristlabs/asttokens/issues/79
+ tests/test_astroid.py
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}