summaryrefslogtreecommitdiff
path: root/dev-python/astroquery
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/astroquery')
-rw-r--r--dev-python/astroquery/Manifest3
-rw-r--r--dev-python/astroquery/astroquery-0.3.6.ebuild61
-rw-r--r--dev-python/astroquery/metadata.xml17
3 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/astroquery/Manifest b/dev-python/astroquery/Manifest
new file mode 100644
index 000000000000..7c2b4dd11cc9
--- /dev/null
+++ b/dev-python/astroquery/Manifest
@@ -0,0 +1,3 @@
+DIST astroquery-0.3.6.tar.gz 2879493 BLAKE2B 893dc6e961fc983cf5c6892607b74d7f3302bc6396c2772129bfb719003b5263be52e8bd9bb5eebaa271c8b7d5ac9103b6c001798aba7051d4203f5abb70d480 SHA512 631e42ef2c50b7a876efeff5a498707734a3ce29e9b5ad7074150272db4928b4f32572d1bfef37c10cb26c2f8fa39e4c7cc268d61320ba399f8479507b1a2fcd
+EBUILD astroquery-0.3.6.ebuild 1550 BLAKE2B 7968fdd6da0993f1d120bee2a8f038b938d61c866a95e1f235bf8e9230893ef45fb2d94fdbbcc776af805861102aff1d99d426d11b9f6bfa85da2e95095170ec SHA512 dfe5fa773075575eda80a88c10a0e5e3bebaa4d4c6e52587b03f567f144bc75381b388280775d039de859a7911ce2c2067eca3e1e018452b4e46988210812926
+MISC metadata.xml 647 BLAKE2B d6eaac8a1127e1d3a78cced70785c73dff08a1d4eb8a4fe80d7ed2c11f84da448a530b81023a073712eba304a4e809dd8d6b2454e1059db9e5cbe1926cee46e0 SHA512 d677c42414e0271d73748505e577ec2dcedaf9fccf92413a8f3ad8f47c4823c1c0ea7856e977862581b0ee9e88ac12f1cf25e0e336293feed1f51597a4c6875f
diff --git a/dev-python/astroquery/astroquery-0.3.6.ebuild b/dev-python/astroquery/astroquery-0.3.6.ebuild
new file mode 100644
index 000000000000..1923b8dd52a1
--- /dev/null
+++ b/dev-python/astroquery/astroquery-0.3.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 xdg-utils virtualx
+
+DESCRIPTION="Collection of packages to access online astronomical resources"
+HOMEPAGE="https://github.com/astropy/astroquery"
+SRC_URI="https://github.com/astropy/astroquery/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test"
+
+DOCS=( README.rst )
+
+PYTHON_REQ_USE="test? ( tk )"
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/aplpy[${PYTHON_USEDEP}]
+ dev-python/pyregion[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ xdg_environment_reset
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ virtx esetup.py test
+}
+
+python_compile_all() {
+ if use doc; then
+ python_setup
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/astroquery/metadata.xml b/dev-python/astroquery/metadata.xml
new file mode 100644
index 000000000000..c634ebada8b3
--- /dev/null
+++ b/dev-python/astroquery/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Astroquery is a package containing a collection of tools to use
+ online astronomical databases. It integrates with Astropy and aims
+ to support many services with a uniform API.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">astropy/astroquery</remote-id>
+ <remote-id type="pypi">astroquery</remote-id>
+ </upstream>
+</pkgmetadata>