summaryrefslogtreecommitdiff
path: root/dev-python/astroquery
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/astroquery')
-rw-r--r--dev-python/astroquery/Manifest4
-rw-r--r--dev-python/astroquery/astroquery-0.3.6.ebuild61
-rw-r--r--dev-python/astroquery/metadata.xml17
3 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/astroquery/Manifest b/dev-python/astroquery/Manifest
new file mode 100644
index 000000000000..7ded2fea345e
--- /dev/null
+++ b/dev-python/astroquery/Manifest
@@ -0,0 +1,4 @@
+DIST astroquery-0.3.6.tar.gz 2879493 SHA256 80a8cc8a2b614b3e00357d32e551b01ce1a06a4029e6c620332e19e71ea47b88 SHA512 631e42ef2c50b7a876efeff5a498707734a3ce29e9b5ad7074150272db4928b4f32572d1bfef37c10cb26c2f8fa39e4c7cc268d61320ba399f8479507b1a2fcd WHIRLPOOL 0282141ab710cf4c6b58370f061a5960cccc19360cce8e994d6659702a5d7b1e8d2afa1267f286ca96480bfe88a4b728d3941d06c70aa44a4b75819ddd987097
+EBUILD astroquery-0.3.6.ebuild 1550 SHA256 3492e02acfb4f1f01400e04856b3284f01fa04b73ef8023f5d26d0607cda9c26 SHA512 dfe5fa773075575eda80a88c10a0e5e3bebaa4d4c6e52587b03f567f144bc75381b388280775d039de859a7911ce2c2067eca3e1e018452b4e46988210812926 WHIRLPOOL 376f423a777f14b27d0eb4735b997d3e9261c9347751759c3cddf20cfded512853a4b42ae1d8eb621ac3b5a06e5c879eae45a181ef44a8841ef48686fb18e987
+MISC ChangeLog 666 SHA256 b068b447f0ce63ec4b38cbdf3826013ae92f03dd7cf97399f902eb171b780135 SHA512 686e35d6816daaec67f27e67fe53eb32fbec31b0c2bf36ac86c2aa63a477a95391bb91b2e43f93b2e0d2cfaa3a72086005949c640efed4039c937dd20a7f0769 WHIRLPOOL 21bf34560edceb80db6b5b7eaa449b06dfdf83c9004f1e19644142199e760903dacdb6f2226f6631961bd7b7a12316f123612b5a61f866878b0ff4f33918784e
+MISC metadata.xml 647 SHA256 75dc7e4d89141824a66aefedf3e23b5cb59786b8ea7ae04a70e7fe73a15bec52 SHA512 d677c42414e0271d73748505e577ec2dcedaf9fccf92413a8f3ad8f47c4823c1c0ea7856e977862581b0ee9e88ac12f1cf25e0e336293feed1f51597a4c6875f WHIRLPOOL 38d38f603aa68d9c1aa19b9cdd2eaab039a84e41e7ba36fccdd6287d40489006d46c4e34ea0122d182138ed6ff917e2c7ee3d338150c47dc21b4ea8468170ec5
diff --git a/dev-python/astroquery/astroquery-0.3.6.ebuild b/dev-python/astroquery/astroquery-0.3.6.ebuild
new file mode 100644
index 000000000000..1923b8dd52a1
--- /dev/null
+++ b/dev-python/astroquery/astroquery-0.3.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 xdg-utils virtualx
+
+DESCRIPTION="Collection of packages to access online astronomical resources"
+HOMEPAGE="https://github.com/astropy/astroquery"
+SRC_URI="https://github.com/astropy/astroquery/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test"
+
+DOCS=( README.rst )
+
+PYTHON_REQ_USE="test? ( tk )"
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/aplpy[${PYTHON_USEDEP}]
+ dev-python/pyregion[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ xdg_environment_reset
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ virtx esetup.py test
+}
+
+python_compile_all() {
+ if use doc; then
+ python_setup
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/astroquery/metadata.xml b/dev-python/astroquery/metadata.xml
new file mode 100644
index 000000000000..c634ebada8b3
--- /dev/null
+++ b/dev-python/astroquery/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Astroquery is a package containing a collection of tools to use
+ online astronomical databases. It integrates with Astropy and aims
+ to support many services with a uniform API.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">astropy/astroquery</remote-id>
+ <remote-id type="pypi">astroquery</remote-id>
+ </upstream>
+</pkgmetadata>