summaryrefslogtreecommitdiff
path: root/dev-python/astor/astor-0.8.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/astor/astor-0.8.1.ebuild')
-rw-r--r--dev-python/astor/astor-0.8.1.ebuild15
1 files changed, 5 insertions, 10 deletions
diff --git a/dev-python/astor/astor-0.8.1.ebuild b/dev-python/astor/astor-0.8.1.ebuild
index d3cba04651ba..97d98e91888a 100644
--- a/dev-python/astor/astor-0.8.1.ebuild
+++ b/dev-python/astor/astor-0.8.1.ebuild
@@ -2,9 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8,9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Read/rewrite/write Python ASTs"
@@ -13,14 +12,10 @@ HOMEPAGE="https://pypi.org/project/astor/"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc x86"
-IUSE=""
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ppc64 ~riscv ~sparc x86"
distutils_enable_tests pytest
-python_prepare_all() {
- # Tries to roundtrip every package on the system and is unreliable
- rm -f tests/test_rtrip.py || die
-
- distutils-r1_python_prepare_all
-}
+EPYTEST_IGNORE=(
+ tests/test_rtrip.py
+)