summaryrefslogtreecommitdiff
path: root/dev-python/asteval/asteval-0.9.30.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/asteval/asteval-0.9.30.ebuild')
-rw-r--r--dev-python/asteval/asteval-0.9.30.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/asteval/asteval-0.9.30.ebuild b/dev-python/asteval/asteval-0.9.30.ebuild
deleted file mode 100644
index 9ce6c80225a3..000000000000
--- a/dev-python/asteval/asteval-0.9.30.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Evaluator of Python expression using ast module"
-HOMEPAGE="
- https://newville.github.io/asteval/
- https://github.com/newville/asteval/
- https://pypi.org/project/asteval/
-"
-SRC_URI="
- https://github.com/newville/asteval/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- epytest -o addopts=
-}