summaryrefslogtreecommitdiff
path: root/dev-python/asgiref/asgiref-3.4.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/asgiref/asgiref-3.4.1-r1.ebuild')
-rw-r--r--dev-python/asgiref/asgiref-3.4.1-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/asgiref/asgiref-3.4.1-r1.ebuild b/dev-python/asgiref/asgiref-3.4.1-r1.ebuild
new file mode 100644
index 000000000000..88adb1867561
--- /dev/null
+++ b/dev-python/asgiref/asgiref-3.4.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="ASGI utilities (successor to WSGI)"
+HOMEPAGE="
+ https://asgi.readthedocs.io/en/latest/
+ https://github.com/django/asgiref/
+ https://pypi.org/project/asgiref/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
+
+BDEPEND="
+ test? ( dev-python/pytest-asyncio[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest