summaryrefslogtreecommitdiff
path: root/dev-python/argparse-manpage/argparse-manpage-4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/argparse-manpage/argparse-manpage-4.ebuild')
-rw-r--r--dev-python/argparse-manpage/argparse-manpage-4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/argparse-manpage/argparse-manpage-4.ebuild b/dev-python/argparse-manpage/argparse-manpage-4.ebuild
new file mode 100644
index 000000000000..9cb83d7cb886
--- /dev/null
+++ b/dev-python/argparse-manpage/argparse-manpage-4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically build man-pages for your Python project"
+HOMEPAGE="
+ https://github.com/praiskup/argparse-manpage/
+ https://pypi.org/project/argparse-manpage/
+"
+SRC_URI="
+ https://github.com/praiskup/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pip[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x COLUMNS=80
+ epytest
+}