summaryrefslogtreecommitdiff
path: root/dev-python/argparse-manpage/argparse-manpage-4.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/argparse-manpage/argparse-manpage-4.3.ebuild')
-rw-r--r--dev-python/argparse-manpage/argparse-manpage-4.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/argparse-manpage/argparse-manpage-4.3.ebuild b/dev-python/argparse-manpage/argparse-manpage-4.3.ebuild
new file mode 100644
index 000000000000..b11255bac332
--- /dev/null
+++ b/dev-python/argparse-manpage/argparse-manpage-4.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically build man-pages for your Python project"
+HOMEPAGE="
+ https://github.com/praiskup/argparse-manpage/
+ https://pypi.org/project/argparse-manpage/
+"
+SRC_URI="
+ https://github.com/praiskup/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+BDEPEND="
+ test? (
+ dev-python/pip[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x COLUMNS=80
+ epytest
+}