summaryrefslogtreecommitdiff
path: root/dev-python/argcomplete/argcomplete-1.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/argcomplete/argcomplete-1.10.0.ebuild')
-rw-r--r--dev-python/argcomplete/argcomplete-1.10.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/argcomplete/argcomplete-1.10.0.ebuild b/dev-python/argcomplete/argcomplete-1.10.0.ebuild
new file mode 100644
index 000000000000..7df8a1c38a08
--- /dev/null
+++ b/dev-python/argcomplete/argcomplete-1.10.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Bash tab completion for argparse"
+HOMEPAGE="https://pypi.org/project/argcomplete/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ app-shells/fish
+ app-shells/tcsh
+ )"
+
+python_test() {
+ "${EPYTHON}" test/test.py -v || die
+}