summaryrefslogtreecommitdiff
path: root/dev-python/apsw
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/apsw')
-rw-r--r--dev-python/apsw/Manifest2
-rw-r--r--dev-python/apsw/apsw-3.46.1.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index f462a18e90d3..5fbef7cc4fc9 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -1,3 +1,5 @@
DIST apsw-3.46.0.1.gh.tar.gz 912632 BLAKE2B b2c89def11102a00dde64fa7d7546f50e302dfe4219394d3d6ddd7f66fec455a60689db61a94230f7ef9578069b08ecd826de82b4e8b019107b9a0b6a36c4271 SHA512 894cf6c49d608d9d8eff369dcf42dd3b2f5174cd98a2c471f41773e2c1474c13d31f08402d053fd0869acb5c038e26543caa345d205c46bd3b3ec6aaecda5089
+DIST apsw-3.46.1.0.gh.tar.gz 913223 BLAKE2B c0ad61e61a97471ef677ffe80f3f91e6520c95f8cece225a8086884f34de497714892e4ce0ca375f2ec66f48b8ecb4d38dd5ebdb57cd94050ef5eaee20d5d3ee SHA512 3cd81ceab03dadf10d9c10d645d33b962ba9ec55075bb193eb076f458dde11d5c5c6ec087ec31fc96d011ca1b339a9ffe07cb5d660b8205f6f156baaa0b18c81
EBUILD apsw-3.46.0.1.ebuild 943 BLAKE2B fd208ce9e77fcb01697ac4f1cc3b4ec3aa04fff8d80bdf20ecd0dadc24bb7dd8c6a2013e83692f6ee77a169c80d60bc8b0daf416c27a9fb65ac0de037e99cc56 SHA512 c0d4c1a074ae0107bf885264e56ed97f46eceddc517bc1ec106a256c2dccce303a19cc6078b0b29ba53672d797329ffa95c08b5caf530e65786998af3a052ecb
+EBUILD apsw-3.46.1.0.ebuild 946 BLAKE2B 1700bd4f3792825fa513414af87f9eeee8528ba767e21fb8818c29807e844e91d9bac632d82736bd0b7ee930d893638cfc64efa35d5870f83b688e8ac8a32870 SHA512 edb1078a6610d3ba67a7d83aec77f612b9453ccf36aba7801b7a07bd95ed205e8f773649a227813e2200c9ffc6ddde5e5d37bb427b6c0161d6ed7baebfc2b50a
MISC metadata.xml 700 BLAKE2B 258344a1602daf3e081fdb4c94eda8af6e231def3f02fb80d63691b47d0a503c9caad80893386ce7ef42d6be2985906f3fc5cfedfe5a1044aee04c493f3d0683 SHA512 de73b4eb06d0bcf4c81e544a98ad15231b006d62fe22f6bce7e38740b941b98297fa1a38b00060ff83ae9f3259c5020c7071469f2a3f0d9e4f8f0301cb942081
diff --git a/dev-python/apsw/apsw-3.46.1.0.ebuild b/dev-python/apsw/apsw-3.46.1.0.ebuild
new file mode 100644
index 000000000000..7b49484a85a9
--- /dev/null
+++ b/dev-python/apsw/apsw-3.46.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="
+ https://github.com/rogerbinns/apsw/
+ https://pypi.org/project/apsw/
+"
+SRC_URI="
+ https://github.com/rogerbinns/apsw/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >=dev-db/sqlite-${PV%.*}:3
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ cat >> setup.cfg <<-EOF || die
+ [build_ext]
+ enable=load_extension
+ use_system_sqlite_config=True
+ EOF
+}
+
+python_test() {
+ esetup.py build_test_extension
+ cd "${T}" || die
+ "${EPYTHON}" -m apsw.tests -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}