summaryrefslogtreecommitdiff
path: root/dev-python/apprise
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/apprise')
-rw-r--r--dev-python/apprise/Manifest2
-rw-r--r--dev-python/apprise/apprise-1.9.1.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/apprise/Manifest b/dev-python/apprise/Manifest
index d20b95931dff..a4cfb9da4c88 100644
--- a/dev-python/apprise/Manifest
+++ b/dev-python/apprise/Manifest
@@ -1,3 +1,5 @@
DIST apprise-1.9.0.tar.gz 1753505 BLAKE2B 83dda79cb585387ba3fa0405126274c35bee20e40a91e699441f56341f411e16dd62ff73115e6cde42e0184afffcaa4cb0783e082d0b2c1ed59a58839cfe9c73 SHA512 9b1ebc18f1662cea35186ddf28182e5507d7faf6e13770a4d6448f129c9d4659665ddf502e0cc7e6bd2e67cda41ee94cd0898f53b986af0daae5f905ccdab2eb
+DIST apprise-1.9.1.tar.gz 1778862 BLAKE2B 5c2d919e7d2f105f0636de6495a7ab450551e6cb2fb806f6f28e8f0bc1370c88e1ed0f55bc350a9828def787a43694bc519020ab522c06b70b648e4aefc187dc SHA512 02b96e6bf88858631d62fef7215d25b383015e916f8031fa01c30a44bb15ff6afd9eb8198e99ce107072f2802db25f5abfa033bb2e9752f559b4c6c40f99ac80
EBUILD apprise-1.9.0.ebuild 894 BLAKE2B a1cb6343bd39e876a2a8079463dce97fe552ddc42f3a33204301078bf7dc5d0ffa90f669b48255e8f941754d6c86feacab6d603965424b90a497b2e61834137c SHA512 2c84789341995f4b18646478bfb90dd2cada43cbf38788cfba5319bb3a5b8afbb1fc519f4148c12010b7f9549dc0fd77c3507c9a9757de51045e1c8a434baad0
+EBUILD apprise-1.9.1.ebuild 895 BLAKE2B f7d000baeee5250191d2319d04ee2bdea275c6470decd2d96406c4080efd1d7080204ff451e8ecf3dd3165b2441e1d05d8647ede5746f48f67a64e6e6062fd0b SHA512 67a064e8aecc4b2086a832c27cb2119fb5910795d98522665e91acc0d9ea22f3761a16b2b48e49198df8484b55fd74dfcbdf0fa38f9c060f5fd826ddf568a847
MISC metadata.xml 554 BLAKE2B 5d232c4d5835c5e782d37d9d1697029d4f49c1dfde65cee0527bfd2ed31bb67d680a6a3aa406c2fc1ba033c40efde1e239f2b66996a23c7089d4e6d8a3beb411 SHA512 0e857c991e1347784d908b291a01dba19005985f4976a29fc76522872828f1491d2ece6e9755277167369198dc26beed623beaf9b3d4693a0e0d9e663830b29a
diff --git a/dev-python/apprise/apprise-1.9.1.ebuild b/dev-python/apprise/apprise-1.9.1.ebuild
new file mode 100644
index 000000000000..ff298c31cd7b
--- /dev/null
+++ b/dev-python/apprise/apprise-1.9.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Push Notifications that work with just about every platform"
+HOMEPAGE="
+ https://pypi.org/project/apprise/
+ https://github.com/caronc/apprise/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+IUSE="+dbus mqtt"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ mqtt? ( dev-python/paho-mqtt[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ dev-python/babel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest