summaryrefslogtreecommitdiff
path: root/dev-python/apipkg/apipkg-2.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/apipkg/apipkg-2.1.0.ebuild')
-rw-r--r--dev-python/apipkg/apipkg-2.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/apipkg/apipkg-2.1.0.ebuild b/dev-python/apipkg/apipkg-2.1.0.ebuild
new file mode 100644
index 000000000000..521b20593649
--- /dev/null
+++ b/dev-python/apipkg/apipkg-2.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+MY_P=${P/_/}
+DESCRIPTION="Namespace control and lazy-import mechanism"
+HOMEPAGE="https://pypi.org/project/apipkg/"
+SRC_URI="
+ https://github.com/pytest-dev/apipkg/archive/v${PV/_/}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}