summaryrefslogtreecommitdiff
path: root/dev-python/apipkg/apipkg-1.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/apipkg/apipkg-1.5.ebuild')
-rw-r--r--dev-python/apipkg/apipkg-1.5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/apipkg/apipkg-1.5.ebuild b/dev-python/apipkg/apipkg-1.5.ebuild
new file mode 100644
index 000000000000..63525d9df7f6
--- /dev/null
+++ b/dev-python/apipkg/apipkg-1.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Namespace control and lazy-import mechanism"
+HOMEPAGE="https://pypi.org/project/apipkg/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-pytest-4.patch
+)
+
+distutils_enable_tests pytest