summaryrefslogtreecommitdiff
path: root/dev-python/ansible-compat
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ansible-compat')
-rw-r--r--dev-python/ansible-compat/Manifest2
-rw-r--r--dev-python/ansible-compat/ansible-compat-25.1.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index ea4acc8bcb25..119001c2f0e1 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1,5 +1,7 @@
DIST ansible-compat-24.9.1.gh.tar.gz 76018 BLAKE2B 581199ab65ccc884a3eeef246a8dbe527cac91fc3b588edaf1ad45e7aa83a2e77d44eab8e9dc5d7f2598b02a22fb724ccf235d25592ff8c9de0b7718b9ad5507 SHA512 d5da3cbd29bfb49b9ac68f004eb957edbfdfa303ce204e230117e9964df36c6bcbf3b47ef343d6a77b4f24c390266aebd649a8036cf9e7f29dc350d207ab7409
DIST ansible_compat-24.10.0.tar.gz 81818 BLAKE2B 78afad41dbe2172cb485186d78a488343391b5feb39f233f8584dc65ece8f290b43c8a6b0112db4606329bc5f38a9e44c6e39fd48efcb5562292152d44276539 SHA512 636ccb66be3570bf7ab0a51f991fefe3b4754db3fddb4d45ebd116de2721082e8ad4049e0cdd975431f01daaa4cb9d24ca57a97913fa66ce1f1f47780734ab14
+DIST ansible_compat-25.1.0.tar.gz 87512 BLAKE2B 3547a26cd24656e6b7efc1d5250c3b224d539f08bd4fe1569aa3b2a84123baa0969cf1631d004eaab853b19ecf75a525a2baa6fd179a3737c503734459e78b2d SHA512 81b610f997b5d0fcd348a701e94bf7300175851f8c020af4129d3a95996ae61614004c8286af35f0d64887cdd6ae29ecad4aa22ddca4a9802f85178ebc21830b
EBUILD ansible-compat-24.10.0.ebuild 1631 BLAKE2B e7ee209a3becafe42cbab5f9a44791f761e76110704476fda8e9a7fddb8f05884dfa1b2ccfe65990dbdf409a3e1808a9149a91a8cdd937dcabe82ace54d248e6 SHA512 4be39bded03f45f041f682cb1b7a585a8e471e23315df489e7be19790e2c1dadb4727ee68129a5d46cd530a4c937d02b858af040a1eefbbbcb6e4a20e46043b1
EBUILD ansible-compat-24.9.1.ebuild 1818 BLAKE2B ace93c01b61d04a32c33ccc7450cb9ceb2be8009cc5e7baa4117af835bd4bcc1aed460bd25b8e077a65ecc6a90214f00fc97aa2aaed5b8a218f273454bcb7fad SHA512 84d1934eb613ead748591fe870356122258fc328e1b5fabda2472697e3ca72655e07f31738c8e7ade5d0738ae6b8ad6c8e65d00b9822f6740bcbc188481d72e2
+EBUILD ansible-compat-25.1.0.ebuild 1808 BLAKE2B 5e7b5a21edb6e5d8985dd81e6447607ff36985b2fe1805f7dd9612d9834d8e4a3eaf421576f8cada5ff99ab314f53673e046db93fbe12fad968e068430d3c5b9 SHA512 bd8989c155f750056a97666e3ad8ecb8c3e8ae444a7fe462bf4d6abc4d00e95f2d2ae3664601c115a4330d0d618322ee6f86fc4d1ce5fe16b4378291cbf8360f
MISC metadata.xml 404 BLAKE2B cd6a8ae349cbfd750d8e439a93902221cce72c0c03280ef1e99514981f6a1079bf9e16a9eaf58ad1758e83a82625b508ccf461ff487ddf8c378cdf7fd46260f8 SHA512 15330e4ae03c21f1db7a42cd9efca50a2fe60b828caef1dbb29901f39f4089d6b3a3c593ca2bd01c7873c8ff12b15227d0c8ae09450271d733cc36ff979b3365
diff --git a/dev-python/ansible-compat/ansible-compat-25.1.0.ebuild b/dev-python/ansible-compat/ansible-compat-25.1.0.ebuild
new file mode 100644
index 000000000000..5d0bd8248da6
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-25.1.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.18.1[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.23.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.4.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # All these tests attempt to connect to galaxy.ansible.com
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+ 'test/test_runtime.py::test_load_plugins[modules]'
+ # pip, failing due to internets
+ test/test_runtime_scan_path.py::test_scan_sys_path
+ # internets?
+ test/test_runtime.py::test_runtime_has_playbook
+ # TODO
+ test/test_prerun.py::test_get_cache_dir_relative
+ )
+
+ epytest -o addopts=
+}