summaryrefslogtreecommitdiff
path: root/dev-python/ament_package/ament_package-0.9.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ament_package/ament_package-0.9.2.ebuild')
-rw-r--r--dev-python/ament_package/ament_package-0.9.2.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/dev-python/ament_package/ament_package-0.9.2.ebuild b/dev-python/ament_package/ament_package-0.9.2.ebuild
deleted file mode 100644
index 630b864aa377..000000000000
--- a/dev-python/ament_package/ament_package-0.9.2.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Parser for the manifest files in the ament buildsystem"
-HOMEPAGE="https://github.com/ament/ament_package"
-SRC_URI="https://github.com/ament/ament_package/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- test? (
- dev-python/flake8[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- py.test || die
-}