summaryrefslogtreecommitdiff
path: root/dev-python/aiorpcX/aiorpcX-0.19.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aiorpcX/aiorpcX-0.19.1.ebuild')
-rw-r--r--dev-python/aiorpcX/aiorpcX-0.19.1.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-python/aiorpcX/aiorpcX-0.19.1.ebuild b/dev-python/aiorpcX/aiorpcX-0.19.1.ebuild
index 1dceb3bd58c3..89eb9710f38e 100644
--- a/dev-python/aiorpcX/aiorpcX-0.19.1.ebuild
+++ b/dev-python/aiorpcX/aiorpcX-0.19.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_8 )
+PYTHON_COMPAT=( python3_{8..9} )
inherit distutils-r1
@@ -26,3 +26,13 @@ BDEPEND="
)"
distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # require Internet
+ tests/test_socks.py::TestSOCKSProxy::test_create_connection_resolve_good
+ )
+
+ pytest -vv ${deselect[@]/#/--deselect } ||
+ die "Tests failed with ${EPYTHON}"
+}