summaryrefslogtreecommitdiff
path: root/dev-python/aiohttp-oauthlib/aiohttp-oauthlib-0.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aiohttp-oauthlib/aiohttp-oauthlib-0.1.0.ebuild')
-rw-r--r--dev-python/aiohttp-oauthlib/aiohttp-oauthlib-0.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/aiohttp-oauthlib/aiohttp-oauthlib-0.1.0.ebuild b/dev-python/aiohttp-oauthlib/aiohttp-oauthlib-0.1.0.ebuild
new file mode 100644
index 000000000000..8ab895d87dfc
--- /dev/null
+++ b/dev-python/aiohttp-oauthlib/aiohttp-oauthlib-0.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+inherit distutils-r1
+
+DESCRIPTION="This project provides first-class OAuth library support for aiohttp"
+HOMEPAGE="https://git.sr.ht/~whynothugo/aiohttp-oauthlib"
+SRC_URI="https://git.sr.ht/~whynothugo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="ISC"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-3.0.0[${PYTHON_USEDEP}]"
+
+BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${PN}-v${PV}"