summaryrefslogtreecommitdiff
path: root/dev-python/aiohttp-jinja2
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aiohttp-jinja2')
-rw-r--r--dev-python/aiohttp-jinja2/Manifest6
-rw-r--r--dev-python/aiohttp-jinja2/aiohttp-jinja2-0.15.0.ebuild51
-rw-r--r--dev-python/aiohttp-jinja2/aiohttp-jinja2-1.4.2.ebuild2
-rw-r--r--dev-python/aiohttp-jinja2/metadata.xml2
4 files changed, 4 insertions, 57 deletions
diff --git a/dev-python/aiohttp-jinja2/Manifest b/dev-python/aiohttp-jinja2/Manifest
index effb57668575..a3f2d46dc3f4 100644
--- a/dev-python/aiohttp-jinja2/Manifest
+++ b/dev-python/aiohttp-jinja2/Manifest
@@ -1,5 +1,3 @@
-DIST aiohttp-jinja2-0.15.0.tar.gz 51183 BLAKE2B e19ca813f36ac746a84812ec278a3de43e6e24eaafcf949fd18a32c99f460ded03f4dc97171fe1493174a8e2c51543b8c1afcdec51c4688f4fb0b7781287cc03 SHA512 084714cd2376b93f32cdcebc1971d4aaa704a177524b00f322e0347c15ab8085960a68a3760be056e391410f01b6b637eb59db54fccf54d09ba53a9ea03a01db
DIST aiohttp-jinja2-1.4.2.tar.gz 54328 BLAKE2B 3d6aaeb03bbb89516a92fa877ee95a2fd27ab83666a03ca12e78f1744b82797faf2547bf55118618cbd979d80779a9571dfcfe9036bc84142563ede55cfbc1a1 SHA512 7bdaee97efe90a0009cd78a4e46dc80cfeb661c2d5561fdb1b1a1ff098abba8667260bb908e3227edd6601c2412812d0311461942568a8aabf07a164ea2f290e
-EBUILD aiohttp-jinja2-0.15.0.ebuild 1080 BLAKE2B 79c5f9ac7a6d1b25fc494a3574c9127f42de3046433c5a3c07bfb1ebbd0b5764d73e30eb87dae1486be98a8cde8e299ba2e28913d832f980fe7327520055e4bf SHA512 dadd8b7326252f151b00440d2bcde8eed37493c9c44283bfaa860a8dd308d9581f8e66a14d181916826ebcdbad1ab87fed70d5fe14b0765ceb99966183ead5a8
-EBUILD aiohttp-jinja2-1.4.2.ebuild 835 BLAKE2B 94a5a9a23474bf9d8b170df4295f7c9529b6ed93b6365c91621616af028f814b402d166bcca0512eec21f165432c20a0bd773300efecffc0d3df39a89be5911e SHA512 ec7546c1cea7828a28369cdffea06d1084c59eb34fd962508aa1cba73b2f56db9283f2090ac826e9af944cf8958ce1e29a4d109467062b57bc345dba8ede3fe0
-MISC metadata.xml 408 BLAKE2B df678e57a82a1c6a818983506af4a0397469497ec15da8a70aa021b77b60b4b4d14f8c37d821c655fb1c92dc75da69bd37ac487d9937d87c14d6338de8bad803 SHA512 bd5b6da5b67af78a148ec4a95378caa391dee95591b6888028d5427000d38411931559332bf0508c201691e04b8b417acbc5dc026858c546e6843d6779607e22
+EBUILD aiohttp-jinja2-1.4.2.ebuild 841 BLAKE2B 25f59019b996241edc0740c400c7ba158c2db205cbbe2a415d7531b0151cb8261e8786321adf84070476c0c4b2d3a45c103180958992d4bd6b7cb1278fa24b7c SHA512 53fd56354bfb1d76fcf8019822f1aa63e10838ec5441c02754696715e74e0a9b76416fec6b6876bfac4eef909ad3ee08080f212bec504da9968535b7783bab86
+MISC metadata.xml 408 BLAKE2B 916a837821dc02a0eda9ed9c5baa16d70426f4d3979a51b68d4516bc1c87cdc9b097528d4c31540513ecefe056031673a75e3ef6a73c27559dc10675d0b19651 SHA512 16235d6f61135b0caeceaf161cf98e700ac13cc136edeb501280b60bc4dfff6734f80523baaab0982cfef3a84c7a34734e4020ac31a028095967953f04291275
diff --git a/dev-python/aiohttp-jinja2/aiohttp-jinja2-0.15.0.ebuild b/dev-python/aiohttp-jinja2/aiohttp-jinja2-0.15.0.ebuild
deleted file mode 100644
index d06f6beff00b..000000000000
--- a/dev-python/aiohttp-jinja2/aiohttp-jinja2-0.15.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python3_{7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="jinja2 template renderer for aiohttp.web"
-HOMEPAGE="https://github.com/aio-libs/aiohttp-jinja2"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/aiohttp-2.3.9[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? (
- >=dev-python/pytest-3.2.2[${PYTHON_USEDEP}]
- >=dev-python/pytest-aiohttp-0.3.0[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( CHANGES.txt README.rst )
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- pytest -vv tests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/aiohttp-jinja2/aiohttp-jinja2-1.4.2.ebuild b/dev-python/aiohttp-jinja2/aiohttp-jinja2-1.4.2.ebuild
index 6afda9ed0652..12b9970dfdaf 100644
--- a/dev-python/aiohttp-jinja2/aiohttp-jinja2-1.4.2.ebuild
+++ b/dev-python/aiohttp-jinja2/aiohttp-jinja2-1.4.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
diff --git a/dev-python/aiohttp-jinja2/metadata.xml b/dev-python/aiohttp-jinja2/metadata.xml
index f9d1eb44fbde..008342ee256e 100644
--- a/dev-python/aiohttp-jinja2/metadata.xml
+++ b/dev-python/aiohttp-jinja2/metadata.xml
@@ -7,7 +7,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
- <remote-id type="pypi">aiohttp_jinja2</remote-id>
+ <remote-id type="pypi">aiohttp-jinja2</remote-id>
<remote-id type="github">aio-libs/aiohttp-jinja2</remote-id>
</upstream>
</pkgmetadata>