summaryrefslogtreecommitdiff
path: root/dev-python/aiohttp-cors/aiohttp-cors-0.5.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aiohttp-cors/aiohttp-cors-0.5.3.ebuild')
-rw-r--r--dev-python/aiohttp-cors/aiohttp-cors-0.5.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/aiohttp-cors/aiohttp-cors-0.5.3.ebuild b/dev-python/aiohttp-cors/aiohttp-cors-0.5.3.ebuild
new file mode 100644
index 000000000000..25e033410ba1
--- /dev/null
+++ b/dev-python/aiohttp-cors/aiohttp-cors-0.5.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements CORS support for aiohttp asyncio-powered asynchronous HTTP server"
+HOMEPAGE="https://github.com/aio-libs/aiohttp-cors"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/aio-libs/aiohttp-cors"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/aiohttp-1.1.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-pylint[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # for some reason, it is installed by 'setup.py test' on py!=3.4
+ # TODO: investigate
+ sed -i -e '/typing/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}