summaryrefslogtreecommitdiff
path: root/dev-python/aiohttp
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aiohttp')
-rw-r--r--dev-python/aiohttp/Manifest2
-rw-r--r--dev-python/aiohttp/aiohttp-3.11.11.ebuild135
2 files changed, 137 insertions, 0 deletions
diff --git a/dev-python/aiohttp/Manifest b/dev-python/aiohttp/Manifest
index d9c635b2bb2f..886ee28a3d56 100644
--- a/dev-python/aiohttp/Manifest
+++ b/dev-python/aiohttp/Manifest
@@ -1,7 +1,9 @@
DIST aiohttp-3.10.10.tar.gz 7542993 BLAKE2B edc9808937892e2915b591a3d5b9e2be8401a67e6421ada8c49e27cfa1ee67283465d17e3c3a77f7579d4ed45df39884a2f9e336429ef7d64adf351ce7507a85 SHA512 c6928d989c110c323347b6f5b0a90c42e17924b4121455a240f5a15d87f939580640ba0f8d576f8254e484e5b631ec4562a2fb4e6c86402924b1892a6d72aff8
DIST aiohttp-3.11.10.tar.gz 7668832 BLAKE2B e2a8637f1d26ec1bb64d344aebdcf123bb918055185cf40d444d6d02fdf40c2b1ea36ce168b9d4c1e2003e877634d66c456e446cf01a51c9ec086adf1be0a9eb SHA512 06c4bf434705151cd5aa8d4a1759ab41e3b5c307dd92eb22f7293d1e1e3b7597a5f927ad3d1e8bcd3a8cdd4b2ebf12fedf72efd50dbf575b61e5aca4d2e54a55
+DIST aiohttp-3.11.11.tar.gz 7669618 BLAKE2B 148c15503ca2b5449b8afe4d0cadb054625cd12c7e3d958547c7ba6b46ca4d4da1b4091db0f97e2003c8bc7a582c36f4c6aba062a8fe0b0894740042853b68e9 SHA512 7b5c6fdf15a3bdae49b28f6955f31f528aff29f635b8bbbe60f0677dea8fbbe5de8e09b3cbb85f8a846942470b9e44c9d287aaf9eb08f8e8d9fab3bd64079edf
DIST aiohttp-3.11.9.tar.gz 7668012 BLAKE2B 5845d14392429f3aa83ce1469679a89badf5e50a6142e98a58704643fa93e290d5d9e4bc27720e8d9f5c62eafdfb0b43f7381a747fae867960e7b5c13a558fee SHA512 b6be296f08fb4421d3e8f206ca1abcd781a275d24da3434ccf049c95ac332a0fe7334f0450d35e57caa505f348485257ffd627924fbfd1795eb579a5475c7187
EBUILD aiohttp-3.10.10.ebuild 3228 BLAKE2B 9460d28a9b9d85addbb378a77575cbeadec2c40f4a172aa16955fe2676bc2cea291e7019dd9480a30afc3c8957f69d05a83f6d6151a187ea8f6e9a59e9de6acc SHA512 0fdc8696e8aae4f3e3a0d7636f135bc6268b18299886df364c7dcff536b6817cd82ed93898065770c7791428e984a657f1ab87472eeac10f639350eea34ee0ab
EBUILD aiohttp-3.11.10.ebuild 3720 BLAKE2B e6737bd006e9b2d6a8bf10c5b560eaf264d11547223d105c51306d42a794ff76203a5554baa06ce33799cf732df3405dc318dde94ba6feec384e9a59058cb79b SHA512 ab8c2c4a8898309c1dbe607026d6c81bf142473eeb62d0b34256edc6a2e2617736b0c3e908746f5054b3e1a67c40f710e86bc199bc39bda808a5ef9a9f607f48
+EBUILD aiohttp-3.11.11.ebuild 3720 BLAKE2B e6737bd006e9b2d6a8bf10c5b560eaf264d11547223d105c51306d42a794ff76203a5554baa06ce33799cf732df3405dc318dde94ba6feec384e9a59058cb79b SHA512 ab8c2c4a8898309c1dbe607026d6c81bf142473eeb62d0b34256edc6a2e2617736b0c3e908746f5054b3e1a67c40f710e86bc199bc39bda808a5ef9a9f607f48
EBUILD aiohttp-3.11.9.ebuild 3676 BLAKE2B e85d83ca4ed77c217e41ae2270a4098a620a2f3b229fcfdd541ae4900110e77ae830c1a47c1f1cf347acce0ed0f835909b4a4c4e502baf3c2bcf95b2777d42d6 SHA512 0915a55c6eddcb93ae4b8c4ec56f9c1fb8acdac87872f550776e30251325cf06670bec608f0c007a97ac98dd631d5cebc68d945e7cc04bff6d9500f9ee617d9a
MISC metadata.xml 379 BLAKE2B dd6b8001c95e4f845c0519d9674158355566938e9e4aaad3234d3ee2a252ebbb4b6ffe3e8272145a39b2b9e59f6b9d19413547789a5873726581040e413f6b8c SHA512 5ea85743abacb6c4ace3ff45d4949ed787055c738afac892f24bf3770c3bba8fe8e5db4267719300d89e610daf334838a1964beab649730427a12007ddcf5e9e
diff --git a/dev-python/aiohttp/aiohttp-3.11.11.ebuild b/dev-python/aiohttp/aiohttp-3.11.11.ebuild
new file mode 100644
index 000000000000..b6ddfae2e7e3
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-3.11.11.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="HTTP client/server for asyncio"
+HOMEPAGE="
+ https://github.com/aio-libs/aiohttp/
+ https://pypi.org/project/aiohttp/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions test-rust"
+
+RDEPEND="
+ >=dev-python/aiodns-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/aiohappyeyeballs-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/aiosignal-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/attrs-17.3.0[${PYTHON_USEDEP}]
+ dev-python/brotlicffi[${PYTHON_USEDEP}]
+ >=dev-python/frozenlist-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/multidict-4.5.0[${PYTHON_USEDEP}]
+ >=dev-python/propcache-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.17.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ <dev-python/async-timeout-6[${PYTHON_USEDEP}]
+ >=dev-python/async-timeout-4.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ native-extensions? (
+ dev-python/cython[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/time-machine[${PYTHON_USEDEP}]
+ ' 'python3*')
+ test-rust? (
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+DOCS=( CHANGES.rst CONTRIBUTORS.txt README.rst )
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # increase the timeout a little
+ sed -e '/abs=/s/0.001/0.01/' -i tests/test_helpers.py || die
+ # xfail_strict fails on py3.10
+ sed -i -e '/--cov/d' -e '/pytest_cov/d' -e '/xfail_strict/d' setup.cfg || die
+ sed -i -e 's:-Werror::' Makefile || die
+
+ distutils-r1_src_prepare
+}
+
+python_configure() {
+ if [[ ! -d tools && ${EPYTHON} != pypy3 ]] && use native-extensions
+ then
+ # workaround missing files
+ mkdir tools || die
+ > requirements/cython.txt || die
+ > tools/gen.py || die
+ chmod +x tools/gen.py || die
+ # force rehashing first
+ emake requirements/.hash/cython.txt.hash
+ > .update-pip || die
+ > .install-cython || die
+ emake cythonize
+ fi
+}
+
+python_compile() {
+ # implicitly disabled for pypy3
+ if ! use native-extensions; then
+ local -x AIOHTTP_NO_EXTENSIONS=1
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # proxy is not packaged
+ tests/test_proxy_functional.py
+ # python_on_whales is not packaged
+ tests/autobahn/test_autobahn.py
+ # benchmarks
+ tests/test_benchmarks_client.py
+ tests/test_benchmarks_client_request.py
+ tests/test_benchmarks_client_ws.py
+ tests/test_benchmarks_cookiejar.py
+ tests/test_benchmarks_http_websocket.py
+ tests/test_benchmarks_http_writer.py
+ tests/test_benchmarks_web_fileresponse.py
+ tests/test_benchmarks_web_middleware.py
+ tests/test_benchmarks_web_response.py
+ tests/test_benchmarks_web_urldispatcher.py
+ )
+
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/test_client_session.py::test_client_session_timeout_zero
+ # broken by irrelevant deprecation warnings
+ tests/test_circular_imports.py::test_no_warnings
+ )
+
+ # upstream unconditionally blocks building C extensions
+ # on PyPy3 but the test suite needs an explicit switch
+ if [[ ${EPYTHON} == pypy3 ]] || ! use native-extensions; then
+ local -x AIOHTTP_NO_EXTENSIONS=1
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_mock,xdist.plugin
+ rm -rf aiohttp || die
+ epytest -m "not internal and not dev_mode" \
+ -p rerunfailures --reruns=5
+}