summaryrefslogtreecommitdiff
path: root/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.3.ebuild')
-rw-r--r--dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.3.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.3.ebuild b/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.3.ebuild
deleted file mode 100644
index 14d3b2f034d5..000000000000
--- a/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.3.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1
-
-DESCRIPTION="Happy Eyeballs for pre-resolved hosts"
-HOMEPAGE="
- https://pypi.org/project/aiohappyeyeballs/
- https://github.com/aio-libs/aiohappyeyeballs/
-"
-SRC_URI="
- https://github.com/aio-libs/aiohappyeyeballs/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-BDEPEND="
- test? (
- >=dev-python/pytest-asyncio-0.23.2[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p asyncio -o addopts=
-}