summaryrefslogtreecommitdiff
path: root/dev-python/agate
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/agate')
-rw-r--r--dev-python/agate/Manifest2
-rw-r--r--dev-python/agate/agate-1.11.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/agate/Manifest b/dev-python/agate/Manifest
index f6dcba35c2cb..2791c1c54c81 100644
--- a/dev-python/agate/Manifest
+++ b/dev-python/agate/Manifest
@@ -1,5 +1,7 @@
DIST agate-1.10.1.tar.gz 203139 BLAKE2B 656cc5f9abcc38848560bb81a9e7b1a8cf498897ea49a98bd3b44f3d625c69047ef3fa32b4a7191d8807c1bee29bd0c5a8d0ed99e1b91e30ea294b8fb436fb3d SHA512 b039fa587d1fc49277860f9876ad1f885f2530e82888ad8a32066f35e3086b5da0cb7aa9a2ed09ea7992efe649d32df27a372f85e4a06e8aca0d6ec8651567b5
DIST agate-1.10.2.tar.gz 203542 BLAKE2B 697aa898756ab256ed8e9bb92a29b3ad1f8edeb7a8b9636d753a74373714d84a6d0a5d4abb8600b52eb510e478f16ca707839a01ab3a05fec72d88e443322dae SHA512 87385515e3ffe88afdeaa1202368d69824501dc5816b40e1f475afd027bbd5229c70e7449485e0845f50203e6749f3a736d16f17752d1bdd040dc92cbcc2461a
+DIST agate-1.11.0.tar.gz 203764 BLAKE2B c652f4f28840b036361fd05d5f1ca612fdb251a055f2e42d3859050907f0c0f0c17cb2a3351d5eb9d96759f18fc6851a501d1d3aabcb2ad257093ee97a96693d SHA512 9134987ed32838565e6d599568d5346e90d4623dca0868d13d134d6333d55f64ee4fc67469c691e1e964c735e14482e18615ca79f25108ffaf24c4da50a28ae6
EBUILD agate-1.10.1.ebuild 1171 BLAKE2B 90e93c4bc429e1114e93109626a06990942f0649a8b136de5cf54b469cd838708d3cf80791d1ee6ee175efdff9b0e463443c4353b8f0b8406a8e9a1dce27d961 SHA512 9b860d55910463987b3beb8882128c889b6816b154984ededf2952eaefebdd7bb53b9c573cfb637061221994344ec873590335fb26825a8043fe32d4b35b8516
EBUILD agate-1.10.2.ebuild 1171 BLAKE2B 90e93c4bc429e1114e93109626a06990942f0649a8b136de5cf54b469cd838708d3cf80791d1ee6ee175efdff9b0e463443c4353b8f0b8406a8e9a1dce27d961 SHA512 9b860d55910463987b3beb8882128c889b6816b154984ededf2952eaefebdd7bb53b9c573cfb637061221994344ec873590335fb26825a8043fe32d4b35b8516
+EBUILD agate-1.11.0.ebuild 1171 BLAKE2B 6699bb891fc9d06e1264aedda20403c4add46007720342906ef5d7e0b654f22e1951e1979002bb8d3b616cb3881fa3e884a540c44702d2ca19338383e93d5c50 SHA512 498215670470f3767d9dd1e714534b2a35980b15d9bbc2592cf9a766821283d10da2e80de4cb898fb78597f9cf86a5eeee848837ce6826c0a2490bfff459a77f
MISC metadata.xml 611 BLAKE2B a288b63c7859d99467f9304b4d8b007b9df6b4345157e3b7363f23757797fa7f84420b8a515f754775de14893c2fba1ddd62fc3757f5b96f791f65b524db41f7 SHA512 3101db1d600b60da2704dd732b898db6d932ef2305a28dbfdc8b221fc7938a72309e1fd27af4567b4930a20f00490ad8d65bd962978df44cf401ddd058442f02
diff --git a/dev-python/agate/agate-1.11.0.ebuild b/dev-python/agate/agate-1.11.0.ebuild
new file mode 100644
index 000000000000..eb0e80daa1c9
--- /dev/null
+++ b/dev-python/agate/agate-1.11.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python data analysis library that is optimized for humans instead of machines"
+HOMEPAGE="
+ https://github.com/wireservice/agate/
+ https://pypi.org/project/agate/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytimeparse-1.1.5[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.0[${PYTHON_USEDEP}]
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/pyicu-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/python-slugify-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/leather-0.3.3-r2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/cssselect-0.9.1[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/furo
+
+EPYTEST_DESELECT=(
+ # require specific locales
+ tests/test_data_types.py::TestDate::test_cast_format_locale
+ tests/test_data_types.py::TestDateTime::test_cast_format_locale
+)