summaryrefslogtreecommitdiff
path: root/dev-python/PyQt6-sip/PyQt6-sip-13.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PyQt6-sip/PyQt6-sip-13.5.1.ebuild')
-rw-r--r--dev-python/PyQt6-sip/PyQt6-sip-13.5.1.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-python/PyQt6-sip/PyQt6-sip-13.5.1.ebuild b/dev-python/PyQt6-sip/PyQt6-sip-13.5.1.ebuild
new file mode 100644
index 000000000000..26477c15c095
--- /dev/null
+++ b/dev-python/PyQt6-sip/PyQt6-sip-13.5.1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/_}
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="sip module support for PyQt6"
+HOMEPAGE="https://www.riverbankcomputing.com/software/sip/"
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="0"
+KEYWORDS="~amd64"