summaryrefslogtreecommitdiff
path: root/dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.4.0.ebuild')
-rw-r--r--dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.4.0.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.4.0.ebuild b/dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.4.0.ebuild
index e71deb8e4d3f..fac59ec70b21 100644
--- a/dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.4.0.ebuild
+++ b/dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.4.0.ebuild
@@ -3,6 +3,7 @@
EAPI=8
+DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=sip
PYPI_NO_NORMALIZE=1
PYPI_PN=${PN/-/_}
@@ -41,8 +42,9 @@ src_prepare() {
PATH=${T}/cxx:${PATH}
}
-src_configure() {
+python_configure_all() {
append-cxxflags -std=c++17 # for old gcc / clang that use <17 (bug #892331)
+ append-cxxflags ${CPPFLAGS} # respect CPPFLAGS
DISTUTILS_ARGS=(
--jobs=$(makeopts_jobs)